AWS Builder Center: Learn, Build and Connect with builders in the AWS community
AWS Builder Center is the official home for builders on AWS. Share and read what others are working on, follow people who inspire you, explore training and workshops, and find tools to support what you're building.
Wie behebe ich Fehler bei einem ElastiCache for Redis-Snapshot oder -Backup, der hängen bleibt oder ausfällt, wenn ich ihn in einen S3-Bucket kopiere?
Lesedauer: 2 Minute
0
Ich möchte Fehler bei einem Amazon ElastiCache for Redis-Snapshot beheben, der hängen geblieben ist oder ausgefallen ist, als ich versuchte, ihn in einen Amazon Simple Storage Service (Amazon S3)-Bucket zu kopieren.
Kurzbeschreibung
Ein ElastiCache-Snapshot steckt möglicherweise fest oder schlägt fehl, wenn Sie ihn aus den folgenden Gründen in einen Amazon S3-Bucket kopieren:
Der Amazon S3-Ziel-Bucket befindet sich nicht in derselben AWS-Region wie der Snapshot.
Amazon S3 verfügt nicht über die erforderliche Berechtigung für den Zugriff auf ElastiCache.
Für den Benutzer wurde eine falsche AWS Identity and Access Management (IAM) -Richtlinie für den Zugriff auf einen Amazon S3-Bucket festgelegt.
Stellen Sie sicher, dass Sie ElastiCache Zugriff auf Ihren Amazon S3-Bucket gewähren. Überprüfen Sie die Fehlermeldungen, um festzustellen, ob Amazon S3-Berechtigungsprobleme die Ursache für das hängengebliebene oder fehlgeschlagene Kopieren in den Amazon S3-Bucket sind.
Stellen Sie sicher, dass Sie in Ihrem Cluster kein Daten-Tiering verwenden. Standardmäßig ist das Daten-Tiering aktiviert, wenn Sie eine Redis-Engine Version 6.2 oder höher mit der rdg -Cache-Knotenfamilie verwenden.