MediaConvert job failing with 1060 when clipping video

0

Hi,
I have issue with clipping video. My input file is simple black screen video, with simple sound, with length 33 seconds. I have been trying to clip this video from 00:00:00:30 to 00:00:00:64 and got the error: "The clipping region 00:00:00:29 to 00:00:00:29 was not found in input number [1]", Error code: 1060. As pointed in documentation, I set "Timecode source: Start at 0" and "Timecode configuration -> Source: Start at 0" and it didn't help.

JobId: 1616602805385-f1j205

MyInputFile: https://tevi-stage.s3.amazonaws.com/public/temp/mapVideo/d9af280a-b8e3-4c9f-a460-1987e7cfaf2d/audio_files/black_screen_with_audio.mp4

My input JSON:
{
"Queue": "arn:aws:mediaconvert:us-east-1:[removed]:queues/Default",
"UserMetadata": {},
"Role": "arn:aws:iam::[removed]:role/MediaConvert___Test",
"Settings": {
"TimecodeConfig": {
"Source": "ZEROBASED"
},
"OutputGroups": [
{
"Name": "File Group",
"Outputs": [
{
"ContainerSettings": {
"Container": "MP4",
"Mp4Settings": {
"CslgAtom": "INCLUDE",
"CttsVersion": 0,
"FreeSpaceBox": "EXCLUDE",
"MoovPlacement": "PROGRESSIVE_DOWNLOAD",
"AudioDuration": "DEFAULT_CODEC_DURATION"
}
},
"VideoDescription": {
"Width": 1920,
"ScalingBehavior": "DEFAULT",
"Height": 1080,
"TimecodeInsertion": "DISABLED",
"AntiAlias": "ENABLED",
"Sharpness": 50,
"CodecSettings": {
"Codec": "H_264",
"H264Settings": {
"InterlaceMode": "PROGRESSIVE",
"ParNumerator": 16,
"NumberReferenceFrames": 3,
"Syntax": "DEFAULT",
"Softness": 0,
"GopClosedCadence": 1,
"GopSize": 90,
"Slices": 1,
"GopBReference": "DISABLED",
"MaxBitrate": 1000,
"SlowPal": "DISABLED",
"ParDenominator": 9,
"EntropyEncoding": "CABAC",
"FramerateControl": "INITIALIZE_FROM_SOURCE",
"RateControlMode": "QVBR",
"QvbrSettings": {
"QvbrQualityLevel": 7,
"QvbrQualityLevelFineTune": 0
},
"CodecProfile": "MAIN",
"Telecine": "NONE",
"MinIInterval": 0,
"AdaptiveQuantization": "AUTO",
"CodecLevel": "AUTO",
"FieldEncoding": "PAFF",
"SceneChangeDetect": "ENABLED",
"QualityTuningLevel": "SINGLE_PASS",
"FramerateConversionAlgorithm": "DUPLICATE_DROP",
"UnregisteredSeiTimecode": "DISABLED",
"GopSizeUnits": "FRAMES",
"ParControl": "INITIALIZE_FROM_SOURCE",
"NumberBFramesBetweenReferenceFrames": 2,
"RepeatPps": "DISABLED",
"DynamicSubGop": "STATIC"
}
},
"AfdSignaling": "NONE",
"DropFrameTimecode": "ENABLED",
"RespondToAfd": "NONE",
"ColorMetadata": "INSERT"
},
"AudioDescriptions": [
{
"AudioTypeControl": "FOLLOW_INPUT",
"AudioSourceName": "Audio Selector 1",
"CodecSettings": {
"Codec": "AAC",
"AacSettings": {
"AudioDescriptionBroadcasterMix": "NORMAL",
"Bitrate": 96000,
"RateControlMode": "CBR",
"CodecProfile": "LC",
"CodingMode": "CODING_MODE_2_0",
"RawFormat": "NONE",
"SampleRate": 48000,
"Specification": "MPEG4"
}
},
"LanguageCodeControl": "FOLLOW_INPUT"
}
]
}
],
"OutputGroupSettings": {
"Type": "FILE_GROUP_SETTINGS",
"FileGroupSettings": {
"Destination": "s3://tevi-stage/public/temp/mapVideo/d9af280a-b8e3-4c9f-a460-1987e7cfaf2d/audio_files/audio_part_1"
}
}
}
],
"AdAvailOffset": 0,
"Inputs": [
{
"InputClippings": [
{
"EndTimecode": "00:00:00:64",
"StartTimecode": "00:00:00:30"
}
],
"AudioSelectors": {
"Audio Selector 1": {
"Offset": 0,
"DefaultSelection": "DEFAULT",
"ProgramSelection": 1
}
},
"VideoSelector": {
"ColorSpace": "FOLLOW",
"Rotate": "DEGREE_0",
"AlphaBehavior": "DISCARD"
},
"FilterEnable": "AUTO",
"PsiControl": "USE_PSI",
"FilterStrength": 0,
"DeblockFilter": "DISABLED",
"DenoiseFilter": "DISABLED",
"InputScanType": "AUTO",
"TimecodeSource": "ZEROBASED",
"FileInput": "s3://tevi-stage/public/temp/mapVideo/d9af280a-b8e3-4c9f-a460-1987e7cfaf2d/audio_files/black_screen_with_audio.mp4"
}
]
},
"AccelerationSettings": {
"Mode": "DISABLED"
},
"StatusUpdateInterval": "SECONDS_60",
"Priority": 0
}

Edited by: Geniusee on Mar 25, 2021 2:16 AM

Edited by: Geniusee on Mar 25, 2021 2:17 AM

Edited by: awsjarede on Apr 8, 2021 9:26 AM, removed AWS account #

gefragt vor 3 Jahren881 Aufrufe
3 Antworten
1
Akzeptierte Antwort

You'll have to calculate the duration of a frame in milliseconds, and then convert that to timecode format HH:MM:SS:FF.

Source frame rate: 30fps
1 frame duration milliseconds: 33.33ms
Desired clipping region: 30ms to 60ms --> so roughly 1 frame

Converting to timecode you would enter it like:
StartTimecode: "00:00:00:01"
EndTimecode: "00:00:00:02"

AWS
beantwortet vor 3 Jahren
0

Hello.
Use the format HH:MM:SS:FF or HH:MM:SS;FF, where HH is the hour, MM is the minute, SS is the second, and FF is the frame number.

You should set:
"StartTimecode": "00:00:30:00"
"EndTimecode": "00:00:64:00",

beantwortet vor 3 Jahren
0

Hi.
Thanks for your answer! But I can't specified 00:00:64:00, because HH:MM:SS;FF, and seconds can't be more than 59 and I want to clip by milliseconds.

beantwortet vor 3 Jahren

Du bist nicht angemeldet. Anmelden um eine Antwort zu veröffentlichen.

Eine gute Antwort beantwortet die Frage klar, gibt konstruktives Feedback und fördert die berufliche Weiterentwicklung des Fragenstellers.

Richtlinien für die Beantwortung von Fragen