手動セキュリティアップデートだと成功しますが、Patch Manager (Linux)だと失敗します。

0

概要

SSMを利用したセキュリティアップデートは失敗しますが、手動でyum update --securityを実行すると成功します。

詳細

以下のAMIを使っても再現はしました。
AMI:ami-08bb5f75961e63185
※構築時にユーザースクリプトの入力は必要です。

#cloud-config
repo_upgrade: none

依存関係がうまく解決できていないのでしょうか? 原因を教えてください。

SSMログ抜粋

Removing grub2-tools.x86_64 1:2.06-14.amzn2 - u due to obsoletes from grub2-tools.x86_64 1:2.06-14.amzn2.0.1 - u
08/02/2023 06:11:43 root [ERROR]: yum update failed with result code: 1, message: [u'1:grub2-tools-2.06-14.amzn2.x86_64 \u306f grub2-common = 1:2.06-14.amzn2 \u3092\u8981\u6c42\u3057\u307e\u3059']
shiyun
gefragt vor 8 Monaten279 Aufrufe
1 Antwort
0

ご認識のとおり、パッケージの互換性のあるバージョンがインストールされていることを確認いただいたほうがよいことと、こちらのrepostにも同じような投稿があり、回答がありましたので英語となりますがご参考ください。

https://repost.aws/questions/QUGWErckBaTxe2yo6MtcKgdw/run-patch-manager-failed-on-amazonlinux2

また、情報センターにも以下の記事がありますのでこちらもご参照ください。 https://repost.aws/ja/knowledge-center/systems-manager-patch-manager-fail

profile picture
beantwortet vor 8 Monaten

Du bist nicht angemeldet. Anmelden um eine Antwort zu veröffentlichen.

Eine gute Antwort beantwortet die Frage klar, gibt konstruktives Feedback und fördert die berufliche Weiterentwicklung des Fragenstellers.

Richtlinien für die Beantwortung von Fragen