Kubernetes version 1.21 is not supported for use with nodegroups.

0

eks cluster 1.21 운영중입니다. 지원일자가 한참 지나서 1.22 로 업데이트를 시도 하고 있으나 nodegroup 이 업데이트가 되지 않아서 진행을 못하고 있습니다. 혹시 경험 있으신 분 도움 부탁드립니다. nodegroup not supported ami version

추가로, force update 진행하는 경우 서비스 중단이 발생하는지도 문의 합니다.

gefragt vor 8 Monaten185 Aufrufe
1 Antwort
0

안녕하세요,

EKS 버전 1.21은 2023년 2월 15일부터 지원이 중단되었으며 지원 종료 이후에는 더 이상 사용되지 않는 버전 (현재 지원되는 최소 버전은 1.23 이상) 으로 노드 그룹을 만들거나 업그레이드할 수 없으므로 이 오류가 표시된다는 점을 알려 드립니다.

따라서 콘솔이나 CLI에서 더 이상 사용되지 않는 버전으로 노드 그룹을 생성하거나 업그레이드할 수 없지만 아래 명령으로 시도하여 현재 유일한 방법이므로 작동하는지 확인할 수 있습니다. 그렇지 않으면 새 클러스터로 마이그레이션해야 합니다.

업그레이드 명령:

aws eks update-nodegroup-version --cluster-name <cluster-name> --nodegroup-name <node-group-name> --force

참고: 명령에 어떤 버전도 언급하지 마십시오.

AWS
sanju_s
beantwortet vor 8 Monaten

Du bist nicht angemeldet. Anmelden um eine Antwort zu veröffentlichen.

Eine gute Antwort beantwortet die Frage klar, gibt konstruktives Feedback und fördert die berufliche Weiterentwicklung des Fragenstellers.

Richtlinien für die Beantwortung von Fragen