RHEL ARM64 Repos out of sync?

0

Firing up new RHEL 9 EC2 ARM64 instance, and immediately trying to do a yum update and it can't. It appears the BaseOS is out of sync (older) with the updated Appstream repo. None of my 12 Reserved Instances, running RHEL9, can yum update either. If I disable BaseOS, it doesn't complain. I can't contact RHEL, since RedHAT says AWS handles RedHAT support. I've tried US-EAST-1, US-EAST-2, and US-WEST-2.

The Appstream Repo, which provides all of the -devel rpms, has newer, updated rpms, which is complaining about older rpms in the BaseOS.

As you can see it wants differing packages for -devel and base versions, which can't happen. Please fix.

Thanks!

Red Hat Enterprise Linux 9 for aarch64 - AppStream from RHUI (RPMs) 27 MB/s | 13 MB 00:00
Red Hat Enterprise Linux 9 for aarch64 - BaseOS from RHUI (RPMs) 40 MB/s | 6.0 MB 00:00
Red Hat Enterprise Linux 9 Client Configuration 18 kB/s | 1.8 kB 00:00
Error: Problem 1: package authselect-compat-1.2.5-1.el9.aarch64 requires authselect(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed

  • cannot install both authselect-1.2.5-2.el9_1.aarch64 and authselect-1.2.5-1.el9.aarch64
  • cannot install the best update candidate for package authselect-compat-1.2.5-1.el9.aarch64
  • cannot install the best update candidate for package authselect-1.2.5-1.el9.aarch64 Problem 2: package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed
  • cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64
  • cannot install the best update candidate for package glibc-devel-2.34-40.el9.aarch64
  • cannot install the best update candidate for package glibc-2.34-40.el9.aarch64 Problem 3: package zlib-devel-1.2.11-34.el9.aarch64 requires zlib(aarch-64) = 1.2.11-34.el9, but none of the providers can be installed
  • cannot install both zlib-1.2.11-35.el9_1.aarch64 and zlib-1.2.11-34.el9.aarch64
  • cannot install the best update candidate for package zlib-devel-1.2.11-34.el9.aarch64
  • cannot install the best update candidate for package zlib-1.2.11-34.el9.aarch64 Problem 4: package libxcrypt-devel-4.4.18-3.el9.aarch64 requires glibc-devel(aarch-64) >= 2.27, but none of the providers can be installed
  • package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed
  • package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed
  • package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed
  • package glibc-2.34-40.el9.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-40.el9 if redhat-rpm-config), but none of the providers can be installed
  • package glibc-2.34-28.el9_0.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-28.el9_0 if redhat-rpm-config), but none of the providers can be installed
  • package glibc-2.34-28.el9_0.2.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-28.el9_0.2 if redhat-rpm-config), but none of the providers can be installed
  • cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-40.el9.aarch64
  • cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-28.el9_0.aarch64
  • cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-28.el9_0.2.aarch64
  • cannot install the best update candidate for package redhat-rpm-config-196-1.el9.noarch
  • cannot install the best update candidate for package libxcrypt-devel-4.4.18-3.el9.aarch64
  • cannot install the best update candidate for package glibc-gconv-extra-2.34-40.el9.aarch64 Problem 5: problem with installed package authselect-compat-1.2.5-1.el9.aarch64
  • package authselect-compat-1.2.5-1.el9.aarch64 requires authselect(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed
  • package authselect-1.2.5-1.el9.aarch64 requires authselect-libs(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed
  • cannot install both authselect-libs-1.2.5-2.el9_1.aarch64 and authselect-libs-1.2.5-1.el9.aarch64
  • cannot install the best update candidate for package authselect-libs-1.2.5-1.el9.aarch64 Problem 6: package gcc-11.3.1-2.1.el9.aarch64 requires glibc-devel >= 2.2.90-12, but none of the providers can be installed
  • package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed
  • package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed
  • package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed
  • package glibc-2.34-40.el9.aarch64 requires glibc-common = 2.34-40.el9, but none of the providers can be installed
  • package glibc-2.34-28.el9_0.aarch64 requires glibc-common = 2.34-28.el9_0, but none of the providers can be installed
  • package glibc-2.34-28.el9_0.2.aarch64 requires glibc-common = 2.34-28.el9_0.2, but none of the providers can be installed
  • cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-40.el9.aarch64
  • cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-28.el9_0.aarch64
  • cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-28.el9_0.2.aarch64
  • cannot install the best update candidate for package glibc-common-2.34-40.el9.aarch64
  • cannot install the best update candidate for package gcc-11.3.1-2.1.el9.aarch64 Problem 7: problem with installed package glibc-devel-2.34-40.el9.aarch64
  • package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed
  • cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64
  • package glibc-langpack-en-2.34-40.el9_1.1.aarch64 requires glibc = 2.34-40.el9_1.1, but none of the providers can be installed
  • cannot install the best update candidate for package glibc-langpack-en-2.34-40.el9.aarch64

You can even take the AMI Image directly from RHEL, https://access.redhat.com/solutions/15356 and try and do a yum update, on install and get: [root@ip-172-30-3-97 ~]# yum update Updating Subscription Management repositories. Unable to read consumer identity

This system is not registered with an entitlement server. You can use subscription-manager to register.

Red Hat Enterprise Linux 9 for aarch64 - AppStream from RHUI (RPMs) 65 MB/s | 13 MB 00:00 Red Hat Enterprise Linux 9 for aarch64 - BaseOS from RHUI (RPMs) 35 MB/s | 6.0 MB 00:00 Red Hat Enterprise Linux 9 Client Configuration 19 kB/s | 1.8 kB 00:00 Error: Problem 1: package authselect-compat-1.2.5-1.el9.aarch64 requires authselect(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed

cannot install both authselect-1.2.5-2.el9_1.aarch64 and authselect-1.2.5-1.el9.aarch64
cannot install the best update candidate for package authselect-compat-1.2.3-7.el9.aarch64
cannot install the best update candidate for package authselect-1.2.3-7.el9.aarch64 Problem 2: problem with installed package authselect-compat-1.2.3-7.el9.aarch64
package authselect-compat-1.2.3-7.el9.aarch64 requires authselect(aarch-64) = 1.2.3-7.el9, but none of the providers can be installed
package authselect-compat-1.2.5-1.el9.aarch64 requires authselect(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed
package authselect-1.2.3-7.el9.aarch64 requires authselect-libs(aarch-64) = 1.2.3-7.el9, but none of the providers can be installed
package authselect-1.2.5-1.el9.aarch64 requires authselect-libs(aarch-64) = 1.2.5-1.el9, but none of the providers can be installed
cannot install both authselect-libs-1.2.5-2.el9_1.aarch64 and authselect-libs-1.2.3-7.el9.aarch64
cannot install both authselect-libs-1.2.5-2.el9_1.aarch64 and authselect-libs-1.2.5-1.el9.aarch64
cannot install the best update candidate for package authselect-libs-1.2.3-7.el9.aarch64 (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

If you add --allowerasing, and let it remove authselect-compat on this initial update, then do a: yum group install "development tools", and let it install all the -devel rpms, now you're in for a world of hurt. Any yum updates after that, and with repos out of sync, yum can't update: [root@ip-172-30-3-97 ~]# yum update Updating Subscription Management repositories. Unable to read consumer identity

This system is not registered with an entitlement server. You can use subscription-manager to register.

Last metadata expiration check: 0:03:07 ago on Thu 26 Jan 2023 09:17:10 PM UTC. Error: Problem 1: package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed

cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64
cannot install the best update candidate for package glibc-devel-2.34-40.el9.aarch64
cannot install the best update candidate for package glibc-2.34-40.el9.aarch64 Problem 2: package zlib-devel-1.2.11-34.el9.aarch64 requires zlib(aarch-64) = 1.2.11-34.el9, but none of the providers can be installed
cannot install both zlib-1.2.11-35.el9_1.aarch64 and zlib-1.2.11-34.el9.aarch64
cannot install the best update candidate for package zlib-devel-1.2.11-34.el9.aarch64
cannot install the best update candidate for package zlib-1.2.11-34.el9.aarch64 Problem 3: package libxcrypt-devel-4.4.18-3.el9.aarch64 requires glibc-devel(aarch-64) >= 2.27, but none of the providers can be installed
package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed
package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed
package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed
package glibc-2.34-40.el9.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-40.el9 if redhat-rpm-config), but none of the providers can be installed
package glibc-2.34-28.el9_0.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-28.el9_0 if redhat-rpm-config), but none of the providers can be installed
package glibc-2.34-28.el9_0.2.aarch64 requires (glibc-gconv-extra(aarch-64) = 2.34-28.el9_0.2 if redhat-rpm-config), but none of the providers can be installed
cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-40.el9.aarch64
cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-28.el9_0.aarch64
cannot install both glibc-gconv-extra-2.34-40.el9_1.1.aarch64 and glibc-gconv-extra-2.34-28.el9_0.2.aarch64
cannot install the best update candidate for package redhat-rpm-config-196-1.el9.noarch
cannot install the best update candidate for package libxcrypt-devel-4.4.18-3.el9.aarch64
cannot install the best update candidate for package glibc-gconv-extra-2.34-40.el9.aarch64 Problem 4: package gcc-11.3.1-2.1.el9.aarch64 requires glibc-devel >= 2.2.90-12, but none of the providers can be installed
package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed
package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed
package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed
package glibc-2.34-40.el9.aarch64 requires glibc-common = 2.34-40.el9, but none of the providers can be installed
package glibc-2.34-28.el9_0.aarch64 requires glibc-common = 2.34-28.el9_0, but none of the providers can be installed
package glibc-2.34-28.el9_0.2.aarch64 requires glibc-common = 2.34-28.el9_0.2, but none of the providers can be installed
cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-40.el9.aarch64
cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-28.el9_0.aarch64
cannot install both glibc-common-2.34-40.el9_1.1.aarch64 and glibc-common-2.34-28.el9_0.2.aarch64
cannot install the best update candidate for package glibc-common-2.34-40.el9.aarch64
cannot install the best update candidate for package gcc-11.3.1-2.1.el9.aarch64 Problem 5: problem with installed package glibc-devel-2.34-40.el9.aarch64
package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed
cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64
package glibc-langpack-en-2.34-40.el9_1.1.aarch64 requires glibc = 2.34-40.el9_1.1, but none of the providers can be installed
cannot install the best update candidate for package glibc-langpack-en-2.34-40.el9.aarch64 Problem 6: package annobin-10.73-3.el9.aarch64 requires (gcc >= 11 with gcc < 12), but none of the providers can be installed
package gcc-11.3.1-2.1.el9.aarch64 requires glibc-devel >= 2.2.90-12, but none of the providers can be installed
package glibc-devel-2.34-40.el9.aarch64 requires glibc = 2.34-40.el9, but none of the providers can be installed
package glibc-devel-2.34-28.el9_0.aarch64 requires glibc = 2.34-28.el9_0, but none of the providers can be installed
package glibc-devel-2.34-28.el9_0.2.aarch64 requires glibc = 2.34-28.el9_0.2, but none of the providers can be installed
cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-40.el9.aarch64
cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-28.el9_0.aarch64
cannot install both glibc-2.34-40.el9_1.1.aarch64 and glibc-2.34-28.el9_0.2.aarch64
package gcc-11.2.1-9.4.el9.aarch64 requires cpp = 11.2.1-9.4.el9, but none of the providers can be installed
package glibc-minimal-langpack-2.34-40.el9_1.1.aarch64 requires glibc = 2.34-40.el9_1.1, but none of the providers can be installed
cannot install both cpp-11.2.1-9.4.el9.aarch64 and cpp-11.3.1-2.1.el9.aarch64
cannot install the best update candidate for package glibc-minimal-langpack-2.34-40.el9.aarch64
cannot install the best update candidate for package cpp-11.3.1-2.1.el9.aarch64
cannot install the best update candidate for package annobin-10.73-3.el9.aarch64 (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest'
preguntada hace un año468 visualizaciones
1 Respuesta
0

Contacted RHEL Customer Service, they created Support Ticket over the weekend. Called RHEL 1/31/2023, explained situation, why we don't have a support contract with RHEL, we're AWS customer, but RHEL maintains repos, and they're broken. Escalated to emergency, was notified it'd be looked at first thing 2/1, and by 2/1, AARCH64 repos are working again in AWS. Yay!

Posts on re:Post, & emails to AWS rep trying to get them to escalate to support, since we don't have premium support, went nowhere. Pay for premium RHEL reserved instances EC2s on AWS, better have a backup premium account at RHEL, otherwise, you might be dead for awhile. Zero way to contact anyone about critical infrastructure issues that are easily identifiable. Maybe AWS should setup a cloudwatch alarm for something like that? Hint hint....

respondido hace un año

No has iniciado sesión. Iniciar sesión para publicar una respuesta.

Una buena respuesta responde claramente a la pregunta, proporciona comentarios constructivos y fomenta el crecimiento profesional en la persona que hace la pregunta.

Pautas para responder preguntas