在Sagemaker Studio笔记本上选择镜像类型“Tensorflow 2.6 Python 3.8 GPU 优化”时,出现“没有名为‘tensorflow’的模块”。

0

【以下的问题经过翻译处理】 我在SageMaker Studio上使用“Tensorflow 2.6 Python 3.8 GPU优化”镜像创建了一个简单的笔记本。但是当我尝试运行简单语句"import tensorflow"时,我遇到了错误"no module named 'tensorflow'"。我尝试使用附加到镜像的终端从pip安装'tensorflow'包。但它显示消息"requirement already satisfied"。 我是否遗漏了什么?请帮帮忙。 提前感谢, Praveen

profile picture
EXPERTO
preguntada hace 8 meses30 visualizaciones
1 Respuesta
0

【以下的回答经过翻译处理】 根据您的问题,我了解到您正在尝试在SageMaker Studio中使用TensorFlow 2.6 Python 3.8内核,但无法导入tensorflow。 解决方案: A)如果您的用例版本具有灵活性,则可以尝试使用版本2.6之外的版本。 B)如果不行,您可以尝试以下解决方法:

  1. 使用Tensorflow 2.6 Python 3.8内核打开笔记本
  2. 在笔记本单元格中执行以下行: !sed -i 's|^ *"python",| "/usr/local/bin/python",|g' /usr/local/share/jupyter/kernels/python3/kernel.json
  3. 停止内核
  4. 重新连接内核到您的笔记本。

希望对您有所帮助!

profile picture
EXPERTO
respondido hace 8 meses

No has iniciado sesión. Iniciar sesión para publicar una respuesta.

Una buena respuesta responde claramente a la pregunta, proporciona comentarios constructivos y fomenta el crecimiento profesional en la persona que hace la pregunta.

Pautas para responder preguntas