EC2 instance is not reachable by public IP

0

Hey guys,

I understand there is a million questions like this every day. However mine is different. I did not change a thing in my account. All VPC resources were created by Amazon. I tried all troubleshooting tutorials I could find to no avail. I tried launching instances in 3 different regions - same result. Again I did not create/configure any of the VPC stuff, the instance is launched into a default VPC, default subnet and SG is default too.

Thanks,
Denis

preguntada hace 4 años9503 visualizaciones
2 Respuestas
0
Respuesta aceptada

Hi Denis,

It is expected that you would not be able to reach instance over its public IP with default settings.

default security group associated to the instance, allow inbound traffic from network interfaces (and their associated instances) that are assigned to the same security group.

[+]: https://docs.aws.amazon.com/vpc/latest/userguide/VPC_SecurityGroups.html#DefaultSecurityGroup

Therefore, to access instance over its public IP from your source machine, please add inbound rules to the security group.

To access windows instances:
[+]: https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/authorizing-access-to-an-instance.html#add-rule-authorize-access

To access linux instances:
[+]: https://docs.aws.amazon.com/AWSEC2/latest/UserGuide/authorizing-access-to-an-instance.html#add-rule-authorize-access

I hope this helps.

respondido hace 4 años
profile picture
EXPERTO
revisado hace un año
0

Oh, man. It's so simple it's embarrassing. Thank you very much!

respondido hace 4 años

No has iniciado sesión. Iniciar sesión para publicar una respuesta.

Una buena respuesta responde claramente a la pregunta, proporciona comentarios constructivos y fomenta el crecimiento profesional en la persona que hace la pregunta.

Pautas para responder preguntas