Unable to restore Aurora Serverless V1 snapshot to Aurora Provisioned

1

We are attempting to migrate to provisioned aurora as we need to be able to enable binlog.

We have quite a large database so mysqldump and read in is going to require a very hard to arrange amount of downtime for our service.

When we attempt to restore our snapshot to a provisioned instance, we get this message:

The selected instance class 'db.r3.large' is not supported for the engine version of your snapshot. Please retry with an instance type supported by engine version '5.7.mysql_aurora.2.07.1' and then scale-compute to your desired instance type.

The following documentation suggest that the engine is compatible: https://docs.aws.amazon.com/AmazonRDS/latest/AuroraUserGuide/Concepts.DBInstanceClass.html

Is there something we are missing that makes this impossible?

We have tried a load of different combinations of instance types. We have searched this forum and other sources and can find no information about migrating in this direction, but can also find no information suggesting it shouldn't work.

preguntada hace 2 años896 visualizaciones
2 Respuestas
2
Respuesta aceptada

For anyone else looking for an answer to this, we got it to work in the end by using db.t3.small and the latest engine (no other combination works). You can scale to the instance type you want afterwards.

respondido hace 2 años
profile picture
EXPERTO
revisado hace 22 días
  • This is very interesting, I'll try to reproduce this and bring up to the support if confirmed.

  • I just had the exact issue described in this post and can also validate that only restoring to a db.t3.small instance type worked. I had a snapshot of an Aurora Serverless v1 that I wanted to restore to a Provisioned cluster, and only selecting the 'db.t3.small' instance would allow the operation to take place. All other instance types produced the same error described in this post.

0

Hello

The DB snapshot must have been made from an Amazon RDS DB instance running MySQL version 5.6 or 5.7.

If you want to migrate a MySQL version 5.6 snapshot to Aurora MySQL version 5.7, you can perform the migration in one of the following ways:

Migrate the MySQL version 5.6 snapshot to Aurora MySQL version 5.6, take a snapshot of the Aurora MySQL version 5.6 DB cluster, and then restore the Aurora MySQL version 5.6 snapshot to Aurora MySQL version 5.7.

Upgrade the MySQL version 5.6 snapshot to MySQL version 5.7, take a snapshot of the MySQL version 5.7 DB instance, and then restore the MySQL version 5.7 snapshot to Aurora MySQL version 5.7.

profile picture
GK
respondido hace 2 años
  • Hi, thanks for taking the time to respond.

    We aren't actually on Amazon RDS, so I'm not sure that link applies. I have read through a couple of times and I cant find anything that is relevant.

    We are on Aurora Serverless 5.7 - engine: 5.7.mysql_aurora.2.07.1 (the only option, so I cant upgrade the engine or mysql version). We are trying to move to Provisioned Aurora using the same engine on an r3 instance type. It is an option of the form when you try to restore the snapshot to use Provisioned Aurora, but there seems to be no way to make it work.

No has iniciado sesión. Iniciar sesión para publicar una respuesta.

Una buena respuesta responde claramente a la pregunta, proporciona comentarios constructivos y fomenta el crecimiento profesional en la persona que hace la pregunta.

Pautas para responder preguntas