Je souhaite résoudre les erreurs de démarrage ou de redémarrage de l'instance Amazon CloudWatch Agent.
Brève description
Lorsque vous démarrez ou redémarrez une instance Amazon Elastic Compute Cloud (Amazon EC2) dans CloudWatch Agent, vous pouvez rencontrer les problèmes suivants :
- L'agent CloudWatch est installé, mais lorsque vous démarrez le service, l'erreur 1053 s'affiche.
- L'agent CloudWatch est en cours d'exécution, mais ne démarre pas automatiquement lorsque vous redémarrez une instance Amazon EC2.
Résolution
L'agent CloudWatch est installé, mais lorsque vous démarrez le service, l'erreur 1053 s'affiche
Cette erreur se produit lorsque CloudWatch Agent ne parvient pas à ouvrir ou à localiser le fichier de configuration C:\ProgramData\Amazon\AmazonCloudWatchAgent\amazon-cloudwatch-agent.json. Lorsque CloudWatch Agent tente de revenir en arrière, il n'y a aucun fichier de configuration dans C:\ProgramData\Amazon\AmazonCloudWatchAgent\Configs.
Pour corriger cette erreur, procédez comme suit :
- Créez un fichier de configuration de l'agent CloudWatch. Vous pouvez également créer ou modifier manuellement le fichier de configuration de l'agent CloudWatch.
- Copiez le fichier dans le dossier de configuration C:\ProgramData\Amazon\AmazonCloudWatchAgent\Configs.
- Démarrez le service CloudWatch Agent.
L'agent CloudWatch est en cours d'exécution, mais ne démarre pas automatiquement lorsque vous redémarrez une instance Amazon EC2
Par défaut, CloudWatch Agent démarre automatiquement après le redémarrage d'une instance. Si l'agent ne démarre pas, vérifiez le message d'erreur suivant dans les journaux d'événements de la fenêtre :
« Le service Amazon CloudWatch Agent n'a pas pu démarrer en raison de l'erreur suivante : Le service n'a pas répondu à la demande de démarrage ou de contrôle dans les délais. Un délai d'attente a été atteint (30 000 millisecondes) pendant l'attente de la connexion du service Amazon CloudWatch Agent. »
Cette erreur se produit lorsque l'agent CloudWatch met plus de 30 secondes à démarrer sur une installation Windows Server. Pour résoudre cette erreur de délai, augmentez la valeur du délai d'expiration du service. Pour plus d'informations, consultez la section Un service lent ne démarre pas en raison d'une erreur de délai d’attente dans Windows sur le site Web de Microsoft.