AWS Builder Center: Learn, Build and Connect with builders in the AWS community
AWS Builder Center is the official home for builders on AWS. Share and read what others are working on, follow people who inspire you, explore training and workshops, and find tools to support what you're building.
Comment corriger l'erreur « nfs: server 127.0.0.1 not responding » rencontrée lors du montage de mon système de fichiers Amazon EFS ?
Mon serveur Amazon Elastic File System (Amazon EFS) ne répond pas et renvoie le message d'erreur « nfs: server 127.0.0.1 not responding ». Je souhaite résoudre ce problème.
Brève description
L'erreur « server not responding » peut survenir pour les raisons suivantes :
- Le client NFS ne peut pas se connecter au serveur Amazon EFS.
- Un redémarrage ou un arrêt de l'instance a provoqué une déconnexion du réseau.
- Les ressources sont surexploitées.
- Le réseau connaît des problèmes de performances qui entraînent des erreurs.
- La version spécifique du noyau engendre des problèmes.
- Vous utilisez une configuration de montage incorrecte.
Choisissez la méthode de résolution qui correspond le mieux à votre cas d'utilisation.
Résolution
Le client NFS ne peut pas se connecter au serveur Amazon EFS
Si le client NFS ne parvient pas à se connecter au serveur Amazon EFS, examinez la configuration du réseau pour détecter des erreurs au niveau des paramètres des groupes de sécurité, de la résolution DNS ou des configurations VPC.
Pour tester la connexion, exécutez la commande suivante :
telnet efs-mount-target-IP-address 2049
Si la connexion est établie, la sortie indique une connexion au port spécifié (adresse IP cible du montage EFS) :
ec2-user@ip-172-31-8-105 ~ telnet 172.31.11.149 2049 Trying 172.31.11.149... Connected to 172.31.11.149. Escape character is '^'.
Si la connexion échoue, effectuez les vérifications suivantes :
- Vérifiez que le groupe de sécurité associé à votre système de fichiers EFS autorise bien le trafic entrant sur le port 2049 en provenance du groupe de sécurité du client. Pour en savoir plus, consultez la page Création de groupes de sécurité.
- Vérifiez que le DNS parvient à résoudre l'adresse IP de la cible de montage EFS. Pour en savoir plus, consultez la page Effectuer un montage dans Amazon EC2 avec un nom DNS.
Un redémarrage ou un arrêt de l'instance s'est produit
Pour savoir si un redémarrage ou un arrêt a eu lieu, consultez la métrique StatusCheckFailed dans Amazon CloudWatch pour connaître les arrêts ou redémarrages récents de l'instance.
Les ressources sont surexploitées
Une utilisation élevée du processeur ou de la mémoire peut entraîner des problèmes de performances. Pour évaluer le taux d'utilisation du processeur et de la mémoire, utilisez un outil tel que atop. Pour en savoir plus, consultez le guide A guide to atop command in Linux, disponible sur le site Web de Digital Ocean. Consultez ensuite la métrique CloudWatch CPUUtilization pour votre instance EC2.
Pour résoudre ce problème, vous pouvez mettre à jour votre instance vers un type d'instance plus important.
Problèmes au niveau des performances réseau
Métriques CloudWatch
Des performances réseau médiocres peuvent entraîner des erreurs de montage dans EFS. Pour surveiller les performances de votre réseau, procédez comme suit :
- Ouvrez la console CloudWatch.
- Sélectionnez votre instance EC2.
- Dans la section Métriques, sous EC2, examinez les métriques suivantes :
Entrées/sorties de paquets réseau : une forte variance du débit de paquets peut indiquer un réseau instable.
Entrées/sorties d’octets réseau : une forte variance du débit d'octets peut indiquer un réseau instable.
Erreurs réseau : une augmentation du nombre d'erreurs réseau peut indiquer des problèmes au niveau de l'interface réseau. Pour résoudre un nombre élevé d'erreurs réseau, vous pouvez remplacer votre type d'instance par un type qui offre des performances réseau accrues.
Débit réseau : un débit élevé soutenu indique que vous avez besoin d'une instance à bande passante plus élevée.
Autres outils de surveillance
Vous pouvez également utiliser des outils tiers tels que sar, nload et iftop, disponibles sur le site Web de Die Net.
Identification et réduction des événements de micro-bursting
Le micro-bursting peut entraîner une dégradation soudaine des performances en raison de brèves pics de trafic réseau qui peuvent entraîner des pertes de paquets et des erreurs potentielles. Pour identifier et réduire les événements de micro-bursting, procédez comme suit :
- Ouvrez la console CloudWatch.
- Sélectionnez votre instance EC2.
- Choisissez Surveillance, puis examinez les métriques suivantes :
Entrées/sorties réseau : surveillez le volume du trafic réseau entrant et sortant.
Entrées/sorties de paquets réseau : examinez les augmentations soudaines du nombre de paquets envoyés ou reçus sur de courts intervalles.
Utilisation des crédits du processeur et solde des crédits du processeur : Vérifiez si l’instance rencontre des limitations de processeur qu peuvent être liées à des problèmes de performances réseau.
Remarque : des augmentations soudaines au niveau du trafic réseau ou des débits de paquets peuvent indiquer des événements de micro-bursting. Il est recommandé de surveiller ces métriques sur une période donnée pour pouvoir identifier le comportement de ces augmentations brèves.
Utilisez les données que vous avez collectées pour détecter les augmentations brèves et soudaines du trafic réseau ou du nombre de paquets. Si tout pointe vers un phénomène de micro-bursting, procédez comme suit :
- Ajustez la répartition de votre charge de travail pour équilibrer le trafic réseau et éviter les augmentations soudaines.
- Passez à une instance plus performante ou utilisez une instance activée par Elastic Network Adapter (ENA) pour gérer les demandes du réseau.
Pour en savoir plus, consultez la page Comment déterminer si mon volume Amazon EBS subit un micro bursting et empêcher ce phénomène ?
Résolution de problèmes liés à la version du noyau
Certaines versions de noyau présentent des problèmes qui peuvent entraîner des échecs de montage EFS.
Pour connaître la version d’un noyau, exécutez la commande suivante :
uname -r
Vous obtiendrez une sortie de ce type :
6.1.97-104.177.amzn2023.x86_64
Veillez à utiliser la version 4.3 ou une version ultérieure du noyau.
Configuration de montage incorrecte
Si vous utilisez des options de montage incorrectes, le montage rencontre un échec.
Pour valider vos options de montage, vérifiez la commande de montage qui est utilisée. Lors du montage du système de fichiers, vous devez inclure l'option noresvport :
sudo mount -t nfs -o nfsvers=4.1,rsize=1048576,wsize=1048576,hard,timeo=600,retrans=2,noresvport <mount-target-ip>:/ <mount-point>
Pour en savoir plus sur les options de montage, consultez la page Paramètres de montage NFS recommandés.
Si vous utilisez une configuration de montage correcte mais que le montage échoue malgré tout, veuillez collecter vos informations de journal et contacter AWS Support.
- Sujets
- Storage
- Balises
- Amazon Elastic File System
- Langue
- Français

Contenus pertinents
demandé il y a 2 ans
demandé il y a 3 ans
AWS OFFICIELA mis à jour il y a 6 mois