AWS Builder Center: Learn, Build and Connect with builders in the AWS community
AWS Builder Center is the official home for builders on AWS. Share and read what others are working on, follow people who inspire you, explore training and workshops, and find tools to support what you're building.
Comment résoudre les erreurs de Kibana ou d’OpenSearch Dashboards dans OpenSearch Service ?
Je souhaite résoudre les erreurs de Kibana ou d'OpenSearch Dashboards qui s’affichent dans Amazon OpenSearch Service.
Résolution
En cas de problèmes sous-jacents liés à l'infrastructure ou à la configuration, l'un des messages d'erreur suivants s'affiche :
« OpenSearch Dashboards/Kibana server is not ready yet »
« OpenSearch Dashboards/Kibana did not load properly »
« OpenSearch Dashboards/Kibana did not load properly. Check the server output for more information. »
Pour résoudre ces problèmes et vérifier que votre serveur fonctionne correctement, vérifiez les paramètres suivants :
- Assurez-vous que l'utilisation de votre processeur ne dépasse pas 80 %.
- Assurez-vous que la métrique de pression de mémoire JVM (Java Virtual Machine) ne dépasse pas 75 %.
- Résolvez les erreurs ClusterBlockException et IndexCreateBlockException qui s’affichent.
- Vérifiez si l'espace de stockage de votre domaine OpenSearch Service est insuffisant.
- Répartissez uniformément les partitions sur les nœuds.
- Assurez-vous que les partitions ne dépassent pas la valeur seuil par défaut de 1 000 dans chaque nœud. Pour réduire le nombre de partitions pour vos nœuds, supprimez les index inutiles ou ajoutez d'autres nœuds à votre cluster. Pour supprimer des index, consultez la page API Supprimer l'index sur le site Web d’OpenSearch. Pour plus d'informations sur les bonnes pratiques en matière de partitions, consultez la section Choix du nombre de partitions.
- Vérifiez les nœuds défaillants.
- N'utilisez pas de requêtes groupées qui alourdissent la charge de votre cluster. Si vous devez utiliser des requêtes groupées pour améliorer les performances d'indexation, commencez par une petite taille de groupe et augmentez-la progressivement. Pour plus d'informations, consultez la page Utilisation et dimensionnement des requêtes groupées sur le site Web d'Elastic.
- Vérifiez que la politique basée sur les ressources du domaine OpenSearch Service permet aux utilisateurs et aux rôles Gestion des identités et des accès AWS (AWS IAM) d'interagir avec le service.
Remarque : Vous pouvez également utiliser une politique basée sur l'adresse IP. Vous ne pouvez pas utiliser de politique basée sur l'identité pour configurer l'accès au tableau de bord Kibana ou à OpenSearch Dashboards.
Si vous rencontrez toujours des problèmes, suivez les étapes de dépannage suivantes pour résoudre votre problème.
Résoudre l'erreur « Http request timed out » ou les problèmes d'accès au VPC
Si votre cluster OpenSearch Service se trouve dans un cloud privé virtuel (VPC), le message d'erreur « {"Message":"Http request timed out connecting"} » peut s'afficher. Ce problème se produit lorsqu'un problème d'accessibilité réseau bloque la connexion à Kibana ou à OpenSearch Dashboards.
Pour résoudre ce problème, procédez comme suit :
- Assurez-vous que les groupes de sécurité du VPC autorisent le trafic entrant sur le port 443 depuis l'adresse IP de votre client.
- Si votre client se trouve dans un VPC différent de celui de votre cluster OpenSearch Service, vérifiez que vous avez correctement configuré le client et les sous-réseaux OpenSearch Service. Par exemple, vérifiez vos points de terminaison de VPC, votre connexion d'appairage de VPC, votre VPN ou votre connexion AWS Direct Connect.
- Assurez-vous que les tables de routage de vos sous-réseaux disposent des itinéraires nécessaires pour accéder au domaine OpenSearch Service.
Pour plus d'informations, consultez la section Lancement de vos domaines OpenSearch Service dans un VPC.
Résoudre l'erreur « User: anonymous is not authorized to perform »
Si vous avez activé un contrôle précis des accès et que vous utilisez l'authentification SAML 2.0, le message d'erreur suivant peut s'afficher :
« {"Message":"User: anonymous is not authorized to perform: es:ESHttpGet because no resource-based policy allows the es:ESHttpGet action"} »
Pour résoudre ce problème, procédez comme suit :
- Vérifiez que votre politique basée sur les ressources inclut les autorisations nécessaires pour les utilisateurs SAML 2.0 authentifiés.
- Vérifiez que vous avez correctement mappé les rôles de backend aux attributs SAML 2.0.
Résoudre les problèmes d'intégration de SAML 2.0, Amazon Cognito ou IAM Identity Center
Effectuez les opérations suivantes :
- Vérifiez que vous avez correctement configuré les métadonnées SAML 2.0 dans votre fournisseur d'identité (IdP) et dans OpenSearch Service.
- Vérifiez que vous avez correctement configuré et lié le groupe d'utilisateurs et le groupe d’identités Amazon Cognito à votre domaine OpenSearch Service. Pour résoudre les problèmes, consultez la section Problèmes de configuration courants.
- Assurez-vous d'avoir configuré les rôles et autorisations IAM requis pour l'authentification Amazon Cognito.
Résoudre les problèmes de proxy personnalisé
Si vous rencontrez des problèmes lors de l'utilisation d’un proxy personnalisé, procédez comme suit.
- Utilisez l'URL du point de terminaison pour accéder à Kibana ou à OpenSearch Dashboards sans le proxy afin de vérifier si la configuration du proxy bloque votre accès.
- Vérifiez que votre proxy transmet les requêtes au domaine OpenSearch Service.
- Assurez-vous que votre proxy conserve les en-têtes nécessaires. Pour plus d'informations sur la configuration du proxy NGINX, consultez la section Comment utiliser un proxy NGINX pour accéder à Kibana ou à OpenSearch Dashboards en dehors d'un VPC qui n'utilise pas l'authentification Amazon Cognito ?
Pour un exemple de configuration de proxy, consultez la section Créer une fédération d'identité SAML pour les domaines OpenSearch Service au sein d'un VPC.
Pour l'authentification Amazon Cognito dans un VPC, consultez la section Comment utiliser un proxy NGINX pour accéder à OpenSearch Dashboards avec l'authentification Amazon Cognito depuis l'extérieur d'un VPC ?
Résoudre les problèmes liés aux certificats expirés
Les certificats expirés sur les points de terminaison du proxy peuvent entraîner des problèmes d'accès.
Pour résoudre ces problèmes, procédez comme suit :
- Vérifiez les dates d'expiration des certificats que vous utilisez dans la configuration de votre proxy.
- Renouvelez les certificats expirés et mettez-les à jour dans la configuration de votre proxy.
- Surveillez vos certificats afin d'être averti avant leur expiration.
Résoudre l'erreur « exceeded the number of permissible concurrent requests » ou les problèmes de ressources limitées
Si vos nœuds reçoivent trop de demandes signées avec des informations d'identification IAM différentes, le message d'erreur suivant s'affiche :
« You have exceeded the number of permissible concurrent requests with unique IAM Identities »
Pour résoudre ce problème, procédez comme suit :
- Consolidez vos rôles ou utilisateurs IAM afin de réduire le nombre d'informations d'identification utilisées pour les requêtes.
- Ajoutez des nœuds à votre cluster pour augmenter les seuils de limitation au niveau du nœud.
- Implémentez une logique de nouvelle tentative dans vos applications clientes.
- Augmentez progressivement le volume de requêtes.
- Évitez les opérations en bloc avec plusieurs informations d'identification.
Résoudre les problèmes d'index et de migration lors des déploiements bleu/vert
Vous pouvez rencontrer des problèmes lors des déploiements bleu/vert pour les motifs suivants :
- Conflits de modèles d'index génériques qui affectent l'index Kibana ou OpenSearch Dashboards.
- Documents endommagés dans l'index Kibana ou OpenSearch Dashboards.
Pour résoudre ces problèmes, exécutez la commande suivante pour vérifier s'il existe des modèles d'index incompatibles :
GET _cat/templates
Exemple de sortie :
GET _cat/templates?v name index_patterns order version composed_of my-index-template [*] 0 GET _template/my-index-template { "my-index-template": { "order": 0, "index_patterns": [ "*" ], "settings": { <index-settings> }, "mappings": { <index-mappings> }, "aliases": { <index-alias> } } }
Pour plus d'informations, consultez la page Modèles d’index sur le site Web d’OpenSearch.
Il n'est pas recommandé d'utiliser « index_patterns": "* » dans votre modèle d'index car celui-ci inclut tous les index. Exécutez plutôt la commande suivante pour modifier le modèle d'index afin d'inclure uniquement les index dotés d'un préfixe spécifique :
PUT _template/my-index-template { "index_patterns": ["your-index-prefix-*"], "settings": { index-settings }, "mappings": { index-mappings }, "aliases": { index-alias } }
Remarque : Remplacez your-index-prefix-* par un préfixe d'index, index-settings par vos paramètres d'index, index-mappings par vos mappages d'index et index-alias par votre alias d'index. Pour plus d'informations, consultez la page Modèle d’entrée sur le site Web d’OpenSearch.
Si nécessaire, supprimez l'index Kibana ou OpenSearch Dashboards. Pour plus d'informations, consultez la page API de suppression d’index sur le site Web d'OpenSearch. Puis, restaurez l'index à partir d'un instantané manuel.
Résoudre les problèmes liés aux échecs d'un nœud unique
Les échecs de nœuds individuels peuvent vous faire perdre l'accès à Kibana ou à OpenSearch Dashboards.
Pour résoudre ce problème, procédez comme suit :
- Consultez les métriques de cluster dans Amazon CloudWatch pour les nœuds concernés afin d'identifier les nœuds concernés lorsqu'ils deviennent non sains :
Pour Elasticsearch version 7.10 et antérieures, vérifiez KibanaHealthyNodes.
Pour OpenSearch version 1.x et versions ultérieures, vérifiez OpenSearchDashboardsHealthyNodes. - Augmentez le nombre de nœuds de votre cluster pour une meilleure redondance.
Si vous ne disposez que d'un seul nœud, procédez comme suit pour restaurer l'index .kibana* à partir d’instantanés automatisés :
- Pour répertorier les instantanés automatisés disponibles dans votre référentiel, exécutez la commande suivante :
Remarque : Remplacez repository par cs-automated pour un domaine non chiffré et cs-automated-enc pour un domaine chiffré.GET /_cat/snapshots/repository - Pour afficher la liste des index d'un instantané spécifique, exécutez la commande suivante :
Remarque : Remplacez repo-name par le nom de votre référentiel et snapshot-id par l'ID de l’instantané.GET _snapshot/repo-name/snapshot-id?pretty - Pour restaurer l'index .kibana*, exécutez la commande suivante :
Remarque : Remplacez repo-name par le nom de votre référentiel et snapshot-id par l'ID de l’instantané. Si vous rencontrez des problèmes liés aux autorisations lorsque vous essayez de restaurer l'index, ouvrez un dossier AWS Support. Kibana et OpenSearch Dashboards utilisent tous deux l'index kibana*.POST _snapshot/repo-name/snapshot-id { "indices": ".kibana*" }
Pour plus d'informations, consultez la section Pourquoi mon nœud OpenSearch Service a-t-il planté ?
Résoudre l'erreur « OpenSearch Security not initialized »
Le message d'erreur « OpenSearchSecurityException[OpenSearch Security not initialized for __PATH__] » s'affiche lorsque l'initialisation de sécurité échoue.
Pour vérifier que le plug-in de sécurité a été initialisé pour le domaine, ouvrez l'URL https://kibana-dashboards-url/api/status?pretty dans votre navigateur.
Remarque : Remplacez kibana-dashboards-url par l'URL de votre tableau de bord.
Exemple de sortie :
... Redacted ... { "id": "plugin:securityDashboards@2.15.0", "message": "All dependencies are available", "since": "2025-08-22T11:23:58.243Z", "state": "green", "icon": "success", "uiColor": "secondary" }, ... Redacted ...
Si l'état n’est pas vert dans la sortie, rouvrez l'URL. Si l'état n'est toujours pas vert ou fluctue chaque fois que vous ouvrez l'URL, cela signifie que le plug-in de sécurité n'est pas initialisé correctement. Pour résoudre ce problème, ouvrez un dossier AWS Support.
Résoudre les erreurs « 500 »
Si l'utilisation de votre processeur ou la pression de la mémoire JVM sont élevées, le message d'erreur suivant peut s'afficher :
« {"statusCode":500,"error":"Internal Server Error","message":"An internal server error occurred."} »
Assurez-vous que l'utilisation de votre processeur et la pression de mémoire JVM ne sont pas trop élevées. Pour plus d'informations sur les problèmes rencontrés, consultez les journaux OpenSearch pour plus d'informations sur les erreurs ou les exceptions. Si l'utilisation du processeur et la pression de mémoire JVM sont faibles mais que l'erreur « 500 » persiste, ouvrez un dossier AWS Support.
Résoudre les problèmes liés aux informations manquantes
L'un des messages d'erreur suivants peut s'afficher :
- « OpenSearch Dashboards/Kibana blank page »
- « Unable to see any data on OpenSearch Dashboards/Kibana Visualization or Dashboards »
Si des informations sont manquantes sur la page Détection du tableau de bord, procédez comme suit pour vérifier que vos documents incluent un champ d'horodatage :
- Ouvrez Kibana ou OpenSearch Dashboards.
- Choisissez Gestion des tableaux de bord.
- Choisissez Modèle d’index.
- Sélectionnez votre modèle d'index.
- Pour le champ Heure, sélectionnez Horodatage.
Après avoir configuré un champ d'horodatage pour vos documents, vérifiez les configurations suivantes :
- Pour vérifier que vous avez correctement configuré le champ d'horodatage, exécutez la commande suivante dans la console Outils de développement :
Remarque : Remplacez your-index par le nom de votre index. Dans la sortie, assurez-vous que l'horodatage est défini sur date. S'il n'est pas défini sur date, utilisez l'API _reindex pour définir l'horodatage. Pour plus d'informations, consultez la page Réindexer les données sur le site Web d’OpenSearch.GET your-index/_mappings?pretty - Assurez-vous d'avoir sélectionné la plage de temps appropriée pour votre modèle d'index sur la page Détecter.
- Si vous avez activé un contrôle précis des accès, vérifiez que le rôle de backend dispose des autorisations nécessaires pour afficher les données.
Surveiller l'état d’intégrité de vos nœuds
Kibana et OpenSearch Dashboards utilisent les mêmes ressources CPUUtilization et JVMMemoryPressure que les nœuds OpenSearch Service. Pour vérifier l'état d’intégrité de vos nœuds, consultez la métrique KibanaHealthyNodes ou OpenSearchDashboardsHealthyNodes. Vous pouvez également vérifier l'état d’intégrité de Kibana dans l'onglet État du cluster de votre domaine sur la console OpenSearch Service.
Les métriques d'état d’intégrité indiquent l'un des états suivants du plug-in Kibana ou OpenSearch Dashboards qui s'exécute sur vos nœuds de données :
- Vert indique que Kibana ou OpenSearch Dashboards s'exécute sur tous les nœuds de données et qu'il n’y a aucun problème connu.
- Jaune indique que Kibana ou OpenSearch Dashboards s'exécute sur certains nœuds de données, mais pas sur tous. Kibana ou OpenSearch Dashboards s'exécute lentement dans cet état.
- Rouge indique que Kibana ou OpenSearch Dashboards est défaillant sur tous les nœuds. Kibana ou OpenSearch Dashboards ne s'exécute pas dans cet état et les utilisateurs n'y ont pas accès.
- Sujets
- Analytics
- Balises
- Amazon OpenSearch Service
- Langue
- Français

Contenus pertinents
- Réponse acceptée
demandé il y a 2 ans
demandé il y a 7 mois
demandé il y a 2 ans