Passer au contenu

Comment résoudre les problèmes d'authentification par mot de passe dans mon cluster Amazon Redshift ?

Lecture de 2 minute(s)
0

Je souhaite résoudre un problème d'authentification par mot de passe dans mon cluster Amazon Redshift.

Brève description

Lorsqu'un mot de passe utilisateur de base de données Amazon Redshift expire ou que l'utilisateur utilise un mot de passe incorrect, l'authentification échoue.

Si vous recevez le message d’erreur suivant :

« FATAL: password authentication failed for user »<database user name>« ». (FATAL : échec de l'authentification par mot de passe pour l'utilisateur)

Si vous pouvez accéder au compte superutilisateur Amazon Redshift, vous pouvez réinitialiser le mot de passe de l'utilisateur de la base de données Amazon Redshift. Pour plus d'informations sur les contraintes de mot de passe, consultez la section CRÉER UN UTILISATEUR.

Résolution

Consulter l'historique des modifications pour l'utilisateur de la base de données et la dernière configuration

Procédez comme suit :

  1. Ouvrez la console Amazon Redshift.

  2. Utilisez un client SQL pour vous connecter à Amazon Redshift.

  3. Connectez-vous à Amazon Redshift en tant que superutilisateur.
    Remarque : Si vous devez réinitialiser le mot de passe du compte superutilisateur, consultez la section Comment réinitialiser le mot de passe du compte dans Amazon Redshift ?

  4. Exécutez la commande suivante pour confirmer l'historique des modifications pour l'utilisateur de la base de données et la dernière configuration :

    select * from SYS_USERLOG where user_name = 'database username' order by record_time;

    Remarque : Remplacez le nom d'utilisateur de la base de données par celui de votre base de données Amazon Redshift.

Définir un nouveau mot de passe

Remarque : Dans les commandes suivantes, remplacez nom d'utilisateur de la base de données par le nom d'utilisateur de la base de données Amazon Redshift et nouveau mot de passe par un nouveau mot de passe. Remplacez également nouvelle date d'expiration par une nouvelle date d'expiration.

Pour réinitialiser le mot de passe avec une nouvelle date d'expiration, exécutez la commande ALTER USER avec l’option VALID UNTIL pour définir la nouvelle date :

alter user database username password 'new password' valid until 'new expiration date'

Pour réinitialiser le mot de passe sans date d'expiration, exécutez la commande ALTER USER et définissez l'option VALID UNTIL sur infini :

alter user database username password 'new password' valid until 'infinity'

Informations connexes

SYS_USERLOG

AWS OFFICIELA mis à jour il y a un an