Passer au contenu

Comment résoudre l'erreur « insufficient free IP addresses in subnets » lorsque je crée un groupe de travail Amazon Redshift sans serveur ?

Lecture de 4 minute(s)
0

Lorsque je crée un groupe de travail Amazon Redshift sans serveur, le message d'erreur « insufficient free IP addresses found in subnets » s'affiche.

Brève description

Lorsque vous créez un groupe de travail Amazon Redshift sans serveur et que le nombre d'adresses IP disponibles dans les sous-réseaux est insuffisant, le message d'erreur suivant s'affiche : « Error: Insufficient free IP addresses found in subnets ».

Le message d'erreur s'affiche pour l'une ou plusieurs des raisons suivantes :

  • Vos sous-réseaux contiennent un trop grand nombre de ressources, ce qui laisse un nombre insuffisant d’adresses IP pour votre nouveau cluster Amazon Redshift sans serveur.
  • Votre Amazon Virtual Private Cloud (Amazon VPC) utilise une plage d'adresses IP limitée et les sous-réseaux existants ont épuisé la plupart des adresses IP disponibles.
  • La configuration de votre sous-réseau ne répond pas à l'exigence Amazon Redshift sans serveur d'au moins 3 sous-réseaux dans différentes zones de disponibilité.

Les clusters Amazon Redshift sans serveur nécessitent des sous-réseaux avec une quantité suffisante d'adresses IP. Pour créer un groupe de travail Amazon Redshift sans serveur, vous devez spécifier un Amazon VPC, des groupes de sécurité et au moins 3 sous-réseaux dans différentes zones de disponibilité.

Résolution

Résoudre les problèmes de disponibilité des adresses IP

Remarque : Si des erreurs surviennent lorsque vous exécutez des commandes de l'interface de la ligne de commande AWS (AWS CLI), consultez la section Résoudre des erreurs liées à l’AWS CLI. Vérifiez également que vous utilisez bien la version la plus récente de l'interface.

Pour résoudre les problèmes de disponibilité des adresses IP, prenez les mesures suivantes :

  • Identifiez les sous-réseaux associés au groupe de travail Amazon Redshift sans serveur. Vous pouvez trouver ces informations sur la console Amazon Redshift ou utiliser la commande de l'interface de ligne de commande AWS get-workgroup.
  • Vérifiez les adresses IP disponibles dans les sous-réseaux associés. Vous pouvez consulter les adresses IP disponibles dans les détails du sous-réseau Amazon VPC ou utiliser la commande describe-subnets de l'AWS CLI.
  • Ajoutez des sous-réseaux supplémentaires à l’Amazon VPC. Si les sous-réseaux existants ne disposent pas d’un nombre suffisant d'adresses IP disponibles, créez de nouveaux sous-réseaux dans le même Amazon VPC et associez-les au groupe de travail Amazon Redshift sans serveur. Vérifiez que les nouveaux sous-réseaux se trouvent dans des zones de disponibilité différentes des sous-réseaux existants.

Ajouter un nouveau sous-réseau au groupe de travail

Pour ajouter un nouveau sous-réseau à votre groupe de travail Amazon Redshift sans serveur, procédez comme suit :

  1. Ouvrez la console Amazon VPC.
  2. Créez un nouveau sous-réseau dans une zone de disponibilité au sein du même VPC que les sous-réseaux existants.
  3. Ouvrez la console Amazon Redshift.
  4. Dans le volet de navigation, choisissez Sans serveur, puis Groupes de travail.
  5. Dans la liste de groupes de travail, sélectionnez le nom du groupe de travail que vous souhaitez mettre à jour.
  6. Dans la section Paramètres réseau et de sécurité, sélectionnez Modifier.
  7. Sélectionnez l'onglet Sous-réseaux.
  8. Choisissez Ajouter un sous-réseau, puis sélectionnez le sous-réseau nouvellement créé dans la liste.
  9. Enregistrez les modifications apportées à la configuration du groupe de travail.
  10. Essayez de créer à nouveau le groupe de travail Amazon Redshift sans serveur.

Si le message d'erreur persiste, contactez AWS Support. Vous devrez peut-être fournir des informations telles que l'ID du VPC, les ID de sous-réseau et la configuration du groupe de travail Amazon Redshift sans serveur.

Informations connexes

Création d'un cluster provisionné par Redshift ou d'un groupe de travail Amazon Redshift sans serveur dans un VPC

Sous-réseaux pour les ressources Redshift

AWS OFFICIELA mis à jour il y a un an