Passer au contenu

Comment résoudre l'erreur « Write Not Enabled » (Écriture non activée) pour les journaux d'accès aux compartiments Amazon S3 dans Trusted Advisor ?

Lecture de 2 minute(s)
0

J'ai activé la journalisation des accès au serveur pour mon compartiment Amazon Simple Storage Service (Amazon S3) et AWS Trusted Advisor affiche une erreur « Write Not Enabled » (Écriture non activée).

Brève description

Une fois que vous avez activé la journalisation des accès au serveur Amazon S3, des modifications supplémentaires peuvent entraîner des échecs de connexion ou une erreur « Write Not Enabled » (Écriture non activée). Pour plus d'informations, consultez la section Enregistrement de compartiments Amazon S3.

Résolution

Comme vous avez activé la journalisation des accès au serveur S3, vous pouvez ignorer l'erreur « Write Not Enabled » dans Trusted Advisor. Vous pouvez également activer des listes de contrôle d'accès (ACL) pour les autorisations d'écriture des objets S3 et de lecture de l’ACL de compartiment.

Remarque : Il est recommandé de désactiver les ACL, sauf si vous devez contrôler l'accès individuellement pour chaque objet. Vous pouvez créer une politique de compartiment S3 pour contrôler l'accès à chaque objet de votre compartiment.

Pour activer une ACL pour votre compartiment S3, procédez comme suit :

  1. Ouvrez la console Amazon S3, puis accédez à votre compartiment.
  2. Choisissez l’onglet Autorisations.
  3. Dans Propriété de l'objet, sélectionnez Modifier.
  4. Choisissez Activation des listes de contrôle d'accès, puis sélectionnez Je confirme que les listes de contrôle d'accès seront restaurées.
  5. Pour Propriété de l'objet, sélectionnez Propriétaire du compartiment préféré, puis choisissez Enregistrer les modifications.
  6. Dans Liste de contrôle d’accès (ACL), sélectionnez Modifier.
  7. Pour Groupe de diffusion de journaux S3, sélectionnez Écriture pour les objets et Lecture pour l'ACL du compartiment.
  8. Sélectionnez Enregistrer les modifications.

Pour plus d'informations, consultez la section Accorder des autorisations au groupe de diffusion de journaux à l'aide d'un ACL de compartiment.

AWS OFFICIELA mis à jour il y a 2 ans