Passer au contenu

Docker container fails to start

0

Someone can help me on this issue:

CannotStartContainerError: ResourceInitializationError: failed to create new container runtime task: failed to create shim task: failed to create init process I/O: 1 error occurred: * failed to start binary process: fork/exec /sbin/shim-logger-wrapper: argument list too long : unknown

the container is pulled from ECR. i'am trying to deploy a service on ECS.

demandé il y a 3 ans2,2 k vues

1 réponse
0

This is related to a command in your Dockerfile or docker build file in your ECR that it is expanding as it's executing.

Try pulling image locally and debug it. Here's documentation about to pull image from ECR into Docker on your local machine: https://docs.aws.amazon.com/AmazonECR/latest/userguide/docker-pull-ecr-image.html

AWS

répondu il y a 3 ans

Vous n'êtes pas connecté. Se connecter pour publier une réponse.

Une bonne réponse répond clairement à la question, contient des commentaires constructifs et encourage le développement professionnel de la personne qui pose la question.