Can't update Node.JS version on Gamelift fleets,manual update overrides with the almost deprecated version (Node v10)

0

Is there a way to update Node.JS version to 14 or 16 on AWS Gamelift ?Our fleet runs on Amazon Linux 2 OS . Tried to do it manually on the existing fleet, but it is not compatible with auto generated GameScaleLightweight NodeJS server, so it won't activate the fleet. Tried to create new fleet with new Gamelift build, included node install in the install.sh script, but it didn't install at the specified directory( which was /local/NodeJS ), but a level lower (and i didn't messed up the path). Instead, on specified directory, there was NodeJS version 10 (which was clearly created by Gamelift) Tried to create new fleet with new Gamelift script, that didn't work either. Every time the result is the same, Node.JS version is still 10. Right now, the only thing that works is, revert to AWS SDK v2 , which supports Node.js version 10...

  • Hello Sir, how did you solve the issue? I want to use dynamodb v3 which is supported for node 12 onwards. And it is not compatible with current Gamelift nodejs. Also, using whole AWS sdk v2 for just using few dynamodb function is not a good idea. Please give some suggestions.

UserX
demandé il y a 2 ans356 vues
2 réponses
0

Hey! Thanks for reaching out and sorry for the delay.

You're right that the server script currently runs on NodeJS 10. I've passed this version upgrade on to the service team for prioritization.

AWS
répondu il y a 2 ans
  • Any updates on this ? Thanks in advance

0

The support is terrible and poor. And I can't believe we are waiting this much for this update...

UserX
répondu il y a un an

Vous n'êtes pas connecté. Se connecter pour publier une réponse.

Une bonne réponse répond clairement à la question, contient des commentaires constructifs et encourage le développement professionnel de la personne qui pose la question.

Instructions pour répondre aux questions