[Appium test on Device farm] Getting error as Cannot start the application

0

Hello, I am attempting to run my Appium-Java code on Device Farm. While the code functions correctly locally, it encounters a failure on Device Farm, displaying the error message:

"org.openqa.selenium.SessionNotCreatedException: Could not start a new session. Response code 500. Message: An unknown server-side error occurred while processing the command. Original error: Cannot start the 'com.husqvarna.hfsmobile.dev' application. Consider checking the driver's troubleshooting documentation. Original error: 'com.husqvarna.hfsmobile.features.splash.SplashActivity' or 'com.husqvarna.hfsmobile.dev.com.husqvarna.hfsmobile.features.splash.SplashActivity' never started. Consider checking the driver's troubleshooting documentation."

However, in the video, it is evident that my app launches for a few seconds. I have diligently followed all the guidelines for the Appium Java TestNG project. You can view the details of my Device Farm run here

FYI, I already tried following the solution mentioned here, but no luck

demandé il y a 5 mois320 vues
1 réponse
0

Thank you for reaching out us regarding the above query. I would like to share that the issue could be Appium tried to find the activity in the app to start however that activity can't be started programmatically. So you can try the below to avoid this issue :

  1. set the appActivity and appPackage capabilities so that they're not automatically found by Appium.
  2. If that doesn't work maybe try a wildcard appPackage/Activity name like "myProject*"
  3. Have the developer create an intent specifically for getting past that start up screen that prompts us for a phone number. That screen I believe has a different activity than Appium's looking for.

Having said that, for deep dive on your account specific issue, please feel free to open a support case with AWS using the following link, as it would require sensitive data which cannot be requested publicly.

AWS
INGÉNIEUR EN ASSISTANCE TECHNIQUE
répondu il y a 5 mois
profile picture
EXPERT
vérifié il y a 2 mois
  • Hi Subhayu

    Despite the accurate identification of AppActivity and package by Appium, an unexpected failure occurs. Interestingly, when I manually insert the same values into the YAML file, the process works successfully.

Vous n'êtes pas connecté. Se connecter pour publier une réponse.

Une bonne réponse répond clairement à la question, contient des commentaires constructifs et encourage le développement professionnel de la personne qui pose la question.

Instructions pour répondre aux questions