AWS Builder Center: Learn, Build and Connect with builders in the AWS community
AWS Builder Center is the official home for builders on AWS. Share and read what others are working on, follow people who inspire you, explore training and workshops, and find tools to support what you're building.
Questo contenuto non è disponibile nella lingua selezionata
Lavoriamo costantemente per rendere disponibili i contenuti nella lingua selezionata. Ti ringraziamo per la comprensione.
How do I troubleshoot a CloudFormation stack deployment failure because of an existing AWS KMS key alias?
1 minuti di lettura
0
When I redeploy my AWS CloudFormation stack, the stack fails with the following error: "alias already exists."
Short description
When a CloudFormation stack fails, the stack deletes resources that it created. As a safety measure, AWS Key Management Service (AWS KMS) keys have a minimum 7-day deletion period. If you redeploy the stack before the 7-day deletion period is over, then the stack fails because the alias still exists.