Losing internet access with split tunnel on in aws client VPN

0

I have client VPN set up with split tunnel enabled and have just one route i.e. to target subnet in a VPC. I have gone throug other similar question on AWS re:Post and have made sure that I do not have 0.0.0.0 route in Routes associated with Cvpn endpoint. Also I am not supplying and DNS servers at the moment.

vpn-config local-route-table cvpn-route-table

I can see why I am loosing the internet access which is because a route entry is being pushed down to my local route table (i am using Linux Mint 21 and default openvpn client inbuilt into it to connect) for 0.0.0.0 -> 10.54.0.161 which does not make sense. That route entry should not be pushed by Cvpn to my host machine as I have split tunnel enabled.

Not sure what am I doing wrong.

1 Risposta
1
Risposta accettata

Hope this helps others having issues with CVPN on debian clients.

I had got in touch with AWS Business support about this and they have suggested a workaround in form of using the AWS Client VPN GUI that is available for Linux. When connecting through that software, the default route does not get added but if you use the default open vpn client that gets shipped with linux mint that the issue pops up again.

This should not be happening but they aren't sure about when AWS will prioritize fixing this. So the current solution is using the AWS CVPN GUI. Also the GUI is not supported for newer ubuntu versions but you will need to manually add a few dependencies and then it does work.

Thanks

con risposta un anno fa
profile picture
ESPERTO
verificato 2 mesi fa

Accesso non effettuato. Accedi per postare una risposta.

Una buona risposta soddisfa chiaramente la domanda, fornisce un feedback costruttivo e incoraggia la crescita professionale del richiedente.

Linee guida per rispondere alle domande