AWS RoboMaker - Sample Application - Hello World - Stuck

0

Hi Amazonians,

I am trying the tutorials in AWS RoboMaker Developer Guide, specifically this part:

AWS RoboMaker Developer Guide
Getting Started
Step 3: Configure Environment and Build Applications
Modify and Build Applications
3. In the HelloWorld AWS Cloud9 development environment, choose Resources, then choose Download samples, and then select 1. Hello World.

Link: https://docs.aws.amazon.com/robomaker/latest/dg/gs-build.html

Half way downloading the samples, the terminal prompted me for a decision:

debconf: falling back to frontend: Readline
 Configuring unattended-upgrades 
 ------------------------------- 
 
 A new version (/etc/apt/apt.conf.d/50unattended-upgrades.ucftmp) of 
configuration file /etc/apt/apt.conf.d/50unattended-upgrades is available, but 
the version installed currently has been locally modified.

   1. install the package maintainer's version 
  2. keep the local version currently installed
  3. show the differences between the versions
  4. show a side-by-side difference between the versions
  5. show a 3-way difference between available versions 
  6. do a 3-way merge between available versions
  7. start a new shell to examine the situation

What do you want to do about modified configuration file 50unattended-upgrades? 1
1
1.
1. 
1. install
1. install the package maintainer's version
2
2. 
2.
2. keep         
2. keep the local version currently installed
^[[A    
^[[B
^[[D^[[C

^C

Process exited with code: 0

Pane is dead

I have been trying to get through the prompt by typing the numbers, the sentence, up and down, but everything fails. Finally, I ended the process using Ctrl + C.

This seems like a very dumb question but I just can't continue the tutorial. I have been Googling as well but to no avail. Any help or guide from Amazonians would be much appreciated!! Thank you very much!! :)

posta 4 anni fa358 visualizzazioni
1 Risposta
0

open new terminal and

type
"sudo reboot now "

then open in new terminal then sudo apt-get update then
sudo apt-get upgrade . it will give error saying run some commands run it .

then come robot_ws and colcon build
i think this should work

deb
con risposta 4 anni fa

Accesso non effettuato. Accedi per postare una risposta.

Una buona risposta soddisfa chiaramente la domanda, fornisce un feedback costruttivo e incoraggia la crescita professionale del richiedente.

Linee guida per rispondere alle domande