Debian 12.4 Instance on Lightsail using .htaccess and .htpasswd

0

I want to add mandatory authentication using .htaccess and .htpasswd for a folder called 'admin' So, I created an .htaccess file inside the 'admin' folder with the next code

AuthType Basic AuthName "Área Restringida" AuthUserFile /etc/apache2/authfiles/htpasswd-private Require valid-user

The path for the .htaccess file is /var/www/html/admin

The path for the .htpasswd file is /etc/apache2/authfiles/htpasswd-private, and I used the command 'htpasswd -c /etc/apache2/authfiles/htpasswd-private user1' to create the .htpasswd file with a username and password.

After restarting the Apache services, when attempting to access the URL dominio.mx/admin in the browser, the authentication doesn't appear

My question is, do I need to make some configurations or installations for it to work?

posta 3 mesi fa134 visualizzazioni
2 Risposte
0

Hi LauraEquihua,

Depends that you want to use .htaccess files then you need to do:

AllowOverride AuthConfig

or place data into httpd.conf

Below link may help to understand the logic for Apache.

https://httpd.apache.org/docs/2.4/howto/auth.htm

https://www.howtogeek.com/devops/how-to-setup-basic-http-authentication-on-apache/

Thanks,

profile picture
con risposta 3 mesi fa
0

Hello,

It looks like the community answer is nearly there but the provided URLs are slightly off.

Here is the correct URL for setting up auth on Apache, specifically the section being referenced regarding enabling authentication directives: https://httpd.apache.org/docs/2.4/howto/auth.html#theprerequisites

Here is further documentation on Apache's AllowOverride configuration directive: https://httpd.apache.org/docs/2.4/mod/core.html#allowoverride

AWS
jscta
con risposta 3 mesi fa

Accesso non effettuato. Accedi per postare una risposta.

Una buona risposta soddisfa chiaramente la domanda, fornisce un feedback costruttivo e incoraggia la crescita professionale del richiedente.

Linee guida per rispondere alle domande