Amazon Login not working for AWS Skill Builder

2

https://explore.skillbuilder.aws/learn?cta=dt_topbanner

When I try and log in to AWS Skill Builder with my Amazon account (that I use successfully to log in to my console) I repeatedly get the message "There was a problem Your password is incorrect". I have tried resetting my password but I continue to get this error, although I can consistently login to https://signin.aws.amazon.com. Thanks for any help/direction you can give.

  • I'm able to login but when I try to opt for monthly subscription, i get 403 Forbidden error on the site

Shaley
posta 2 anni fa6258 visualizzazioni
8 Risposte
6

Hi, I have successfully logged in using my regular Amazon account, but every time I try to enroll in a course I get a message saying "Something went wrong".

Anas
con risposta 7 mesi fa
  • I have the same problem. Even tried incognito to see if it was cache or cookies but I just can't login to the skill builder.

5

hi , im getting same problems here , im logging with my amazon.com account but when i try to logging i got "something worng " isnt the password , isnt the wrong account

con risposta 7 mesi fa
2

Update!!

For anyone who is facing the same issue, I contacted the AWS support team regarding this issue and they replied with the below message. Apparently, they face a technical problem.

"At this time, AWS Skill Builder is not accepting new account creation or subscriptions. Customers with Team Subscriptions may experience SSO errors.

Our technical teams are working to resolve this issue. Continue to check skillbuilder.aws for more information. Additional training can be accessed through the Training Events page, which has hundreds of hours of free content, including Twitch-based trainings, live and on-demand webinars, exam preparation resources, and more.

We anticipate your kind understanding in this matter."

Anas
con risposta 7 mesi fa
1

Had the same issue as the topic starter's.

NB! Do not use AWS Console credentials to log into AWS Skill Builder (SB)! Yes, Event if SB has the AWS in it name - IT IS NOT an AWS service! (surprise! hehe) And the redirect to https://signin.aws.amazon.com is WRONG! The login form says "Amazon account". It means not AWS credentials. It means https://www.amazon.com/ (shop) ones. So create them there first!

To handle the "Something went wrong" issue you'll need to ... properly create a SB account! An "ENROLL" button and the Amazon login form DOES NOT handle it! (another surprise! haha) It tries to add a course to existing SB account but it could be missing. So to create an SB account, visit https://skillbuilder.aws/. Then - create an account using your Amazon (shop) credentials (button "Create free account" on top right). After a few screens you'll see a message about the account creation.

Now, you can click an "ENROLL" button, use your Amazon (shop) credentials to log into your SB account and start a course!

Hope, this will help.

con risposta 6 mesi fa
0

This is the console error if it helps. 403 in the networking tab. This is only a guess but it might be an issue with the -> sec-fetch-mode: no-cors

main-es2015.50ddf842b33ba829145e.js:1 ERROR TypeError: Cannot read properties of undefined (reading 'inputElement') at main-es2015.50ddf842b33ba829145e.js:1:17799227 at i.<computed> (polyfills-es2015.fb27b21b92afafa619a3.js:1:79719) at u.invokeTask (polyfills-es2015.fb27b21b92afafa619a3.js:1:54821) at Object.onInvokeTask (main-es2015.50ddf842b33ba829145e.js:1:6771829) at u.invokeTask (polyfills-es2015.fb27b21b92afafa619a3.js:1:54742) at c.runTask (polyfills-es2015.fb27b21b92afafa619a3.js:1:50230) at invokeTask (polyfills-es2015.fb27b21b92afafa619a3.js:1:55871) at invoke (polyfills-es2015.fb27b21b92afafa619a3.js:1:55773) at n.args.<computed> (polyfills-es2015.fb27b21b92afafa619a3.js:1:79432)

con risposta 7 mesi fa
  • Below we see a part of the MDN web docs for sec-fetch-mode: no-cors and is the reason I believe this may be the issue. Following reasoning 403 request is valid and was received but was rejected. Most likely due to a missing element that normally would have come after OAuth, which requires the JS to access an element in response and append to the SSO redirect (MAYBE).

    In addition, JavaScript may not access any properties of the resulting Response. This ensures that ServiceWorkers do not affect the semantics of the Web and prevents security and privacy issues arising from leaking data across domains.

  • I see the new tag good job everyone. sec-fetch-mode: navigate

0

Now, I can sign in to AWS skill builder, so the issue seems to have been resolved!

con risposta 7 mesi fa
0

I still can not login :(

Is it advisable for me to create a new Amazon account since it's still not functioning properly?

I recall being able to utilize Skillbuilder in the past, but if I create a new account, I'll have to begin from the start, losing all of my progress.

Muescha
con risposta 7 mesi fa
-2
Risposta accettata

The credentials you use to sign into AWS Skill Builder are the username and password you use for your Amazon.com account, not your AWS management console (aws.amazon.com) login credentials. Try again using your Amazon.com account, the account you use for purchasing products from Amazon.com.

AWS
con risposta 2 anni fa

Accesso non effettuato. Accedi per postare una risposta.

Una buona risposta soddisfa chiaramente la domanda, fornisce un feedback costruttivo e incoraggia la crescita professionale del richiedente.

Linee guida per rispondere alle domande