Cannot start EC2 instance after changing its type



I have an instance i-0cd0f6d6361e14ec2, which was running okay. Decided to increase capacity.

Stopped the instance, changed instance type. Now it no longer starts. When I try to start it, it goes to "pending" state for a while, then back to "stopped" after about 24 seconds.

I tried changing instance type back and also to a couple of other, more capable types, no luck. Same behavior.

Also tried de-attaching and then re-attaching both volumes vol-0f66f100f638f4fd2 and vol-0f66f100f638f4fd2. Still not able to start.

Also tried creating an AMI out of stopped instance (which took about an hour but succeeded). Launching another instance from this AMI also fails, but instead of "stopped" the new instance ends "terminated" state after about 1 minute or so after launch.

I see the following on the description page of the stopped instance:

State transition reason: Server.InternalError
State transition reason message: Server.InternalError: Internal error on launch

Is this EC2 bug? As there are posts on this forum as of this March about similar errors. I don't think it is a storage size issue as my last full backup is about 50 GB while the volume is at 200 GB.

I opened a developer support plan to resolve this problem sooner, case ID 5971375681, but nothing is happening there for over 8 hours now, I wonder if someone from AWS could comment, as our customers are beginning to panic.

I need help as this is a small mail server, which is critical for our business. Any help?

posta 5 anni fa366 visualizzazioni
1 Risposta

Resolution: Save yourself money and trouble by checking and updating credit card with AWS.

My issue was resolved using the following steps:

  1. First changed the support plan from Basic to Developer - this allowed me to create a technical support incident. This turned out to be not useful, as first response was received only after 13 hours. Apparently, this is outsourced to India, and their time zone is completely out of sync with ours (Pacific Time).

  2. As customers started to panic, upgraded support plan again to Business, and was able to create another incident and chat online with a support person, who traced down the problem to the key used to encrypt our data volume. "Key Management Service" page in AWS console was inaccessible because it believed that I did not complete the registration (incorrectly). One of the links on the info page went to credit card page, with all my cards there showing as expired. After I updated the credit card expiration date, I was able to start the instance.

I hope it helps someone.

con risposta 5 anni fa

Accesso non effettuato. Accedi per postare una risposta.

Una buona risposta soddisfa chiaramente la domanda, fornisce un feedback costruttivo e incoraggia la crescita professionale del richiedente.

Linee guida per rispondere alle domande