スキップしてコンテンツを表示

EBS ボリュームを Amazon EC2 Windows インスタンスにアタッチする方法を教えてください。

所要時間1分
0

新規または既存の Amazon Elastic Block Store (Amazon EBS) ボリュームを Amazon Elastic Compute Cloud (Amazon EC2) Windows インスタンスにアタッチしたいです。

解決策

前提条件 Amazon EBS ボリュームをインスタンスにアタッチするためのすべての前提条件を満たす必要があります。

EBS ボリュームを EC2 Windows インスタンスのルートボリュームとしてアタッチするには、次の手順を実行します。

  1. インスタンスが Stopped 状態であることを確認します
  2. 既存のルートボリュームをデタッチします
  3. Amazon EC2 コンソールまたは AWS コマンドラインインターフェイス (AWS CLI) を使用して、EBS ボリュームを EC2 Windows インスタンスにアタッチします。デバイス名には、/dev/sda1 を使用します。
    注: AWS CLI のコマンドの実行時にエラーが発生する場合は、「AWS CLI でのエラーのトラブルシューティング」を参照してください。また、AWS CLI の最新バージョンを使用していることを確認してください。
  4. リモートデスクトッププロトコル (RDP) を使用して、EC2 Windows インスタンスに接続します。

インスタンスに追加のボリュームをアタッチし、そのボリュームを Windows で使用できるようにするには、以下の手順を実行します。

  1. EBS ボリュームを Windows インスタンスにアタッチし、使用可能なデバイス名を使用します。Nitro ベースのインスタンスについては、「Amazon EBS ボリュームと NVMe」を参照してください。
  2. RDP を使用して EC2 インスタンスに接続します。
  3. EBS ボリュームを Windows で使用できるようにします。Windows PowerShell、DiskPart コマンドインタープリター、またはディスク管理を使用してボリュームにアクセスできます。

**注:**デバイス名を使用してボリュームをインスタンスにアタッチする場合、そのデバイス名を再度使用しないでください。Amazon EC2 では、重複するデバイス名を使用することはできません。重複するデバイス名を使用すると、操作は次のエラーで失敗します。

"unixDevice に無効な値 '/dev/abc' があります。アタッチメントポイント /dev/abc は既に使用中です。"

詳しくは、「使用可能なデバイス名」を参照してください。

関連情報

EBS ボリュームの増加が OS やディスクの管理に反映されていない理由を知りたいです

Amazon EC2 のベストプラクティス

AWS公式更新しました 2年前
コメントはありません

関連するコンテンツ