AWS Builder Center: Learn, Build and Connect with builders in the AWS community
AWS Builder Center is the official home for builders on AWS. Share and read what others are working on, follow people who inspire you, explore training and workshops, and find tools to support what you're building.
ElastiCache クラスターを作成する際のエラーをトラブルシューティングする方法を教えてください。
Amazon ElastiCache クラスターを作成しようとしたところ、作成に失敗します。
簡単な説明
クラスターが独自設計のクラスターか、Amazon ElastiCache Serverless クラスターであるかによって、次の原因でクラスターを作成できないことがあります。
- Amazon Simple Storage Service (Amazon S3) からバックアップを復元したところ、エラーが発生し、復元に失敗する。
- アベイラビリティーゾーンまたは AWS リージョンのキャパシティが、リクエストされたキャッシュノードタイプに対応できない。
- リージョンの特定のアベイラビリティーゾーンでサポートされていないキャッシュノードタイプが選択された。
- キャッシュクラスターの作成に使用したサブネットで、空き IP アドレスが不足している。
- ElastiCache が、レプリケーショングループの暗号化に使用した AWS Key Management Service (AWS KMS) のカスタマーマネージドキーにアクセスできない。
- キャッシュが、ElastiCache Serverless 用の仮想プライベートクラウド (VPC) エンドポイントの作成を許可されていない。
- AWS Identity and Access Management (IAM) ユーザーまたはロールに正しいアクセス許可が欠けている。
- AWS アカウントのサービスクォータを増やす必要がある。
- クラスターの作成中に設定したエンジン固有のパラメータに誤りがある。
解決策
注: AWS コマンドラインインターフェイス (AWS CLI) コマンドの実行中にエラーが発生した場合は、「AWS CLI で発生したエラーのトラブルシューティング」を参照してください。また、AWS CLI の最新バージョンを使用しているかどうかを確認してください。
Amazon S3 バックアップを復元できず、エラーが発生する
いくつかの原因で、Amazon S3 からのバックアップの復元に失敗する場合があります。たとえば、ElastiCache がファイルを取得できない場合や、バケットが別のリージョンにある場合、復元は失敗します。この問題のトラブルシューティングについては、「S3 から ElastiCache クラスターを復元しようとすると発生する、「Create-failed」や「Permission denied」エラーのトラブルシューティング方法を教えてください」を参照してください。
アベイラビリティーゾーンまたは AWS リージョンのキャパシティが、リクエストされたキャッシュノードタイプに対応できない
AWS に十分なオンデマンドキャパシティがない場合、クラスターの作成時に次のエラーメッセージが表示されることがあります。
「Failed to create cache node because requested AZ does not have sufficient capacity.Please try again with another AZ」 (リクエストされた AZ には十分なキャパシティがありません。別の AZ で再試行してください)
アベイラビリティーゾーンまたはリージョンの容量は常に変化します。この問題を解決するには、別の時間にクラスターを作成します。詳細については、「エラーメッセージ: InsufficientCacheClusterCapacity」を参照してください。
リージョンのアベイラビリティーゾーンがキャッシュノードタイプをサポートしていない
リージョンの一部のアベイラビリティーゾーンは、特定のキャッシュノードタイプをサポートしていません。クラスターを作成し、このようなアベイラビリティーゾーンのいずれかを選択すると、次のエラーメッセージが表示されます。
「Cache node type is not currently supported in the AZ.Retry the launch with no availability zone or different AZs」 (現在、この AZ ではキャッシュノードタイプがサポートされていません。アベイラビリティーゾーンを使用せずに起動を再試行するか、他の AZ を使用してください)
特定のキャッシュノードタイプの可用性を確認するには、Amazon Elastic Compute Cloud (Amazon EC2) の AWS CLI コマンド describe-instance-type-offerings を実行します。
aws ec2 describe-instance-type-offerings --location-type availability-zone --filters Name=instance-type,Values=m5.large --region example-region --output table
注: example-region は、実際のリージョンに置き換えます。
選択したサブネットで空き IP アドレスが不足している
ElastiCache クラスターに使用するサブネットに十分な空き IP アドレスがない場合、次のエラーメッセージが表示されることがあります。
「Failed to create Cache Cluster due to insufficient Elastic Network Interface or free IP address」 (Elastic Network インターフェイスまたは空き IP アドレスが不十分なため、キャッシュクラスターを作成できませんでした)
この問題を解決するには、ElastiCache クラスターに設定したサブネットグループを特定します。次に、各サブネットを参照し、十分な量の空き IP アドレスがあることを確認します。詳細については、「Amazon VPC のスケーリングアクティビティ中に発生する、IP アドレス不足に関するエラーのトラブルシューティング方法を教えてください」を参照してください。
サブネット内の使用していない Elastic ネットワークインターフェイスを削除しても、IP アドレスを解放できます。または、必要なアベイラビリティーゾーンのサブネットグループにサブネットを追加すると、追加の空き IP アドレスを割り当てられます。
ElastiCache が AWS KMS カスタマーマネージドキーにアクセスできない
ElastiCache の保存時暗号化では、保存時用のデフォルトのサービスマネージド暗号化または、独自の対称カスタマーマネージド AWS KMS キーを使用できます。クラスターの作成時に KMS キーのアクセス許可を削除、無効化したり、取り消したりした場合、次のエラーメッセージが表示されることがあります。
「Failed to create instance test-cluster due to error accessing AWS Key Management Service (KMS) for Customer Master Key arn:aws:kms:us-east-1:123456:key/1abcd2」
レプリケーショングループの暗号化に使用した AWS KMS キーに対するアクセス許可を削除、無効化したり、取り消したりすることはおすすめしません。AWS KMS は、少なくとも 7 日間の待機期間が経過した後にのみ root キーを削除します。待機期間中に、スケジュールされた削除をキャンセルできます。AWS KMS キーを削除すると、キャッシュを回復できなくなります。
ElastiCache Serverless キャッシュが、VPC エンドポイントの作成を許可されていない
新しい ElastiCache Serverless クラスターを作成する際、ElastiCache は VPC の選択したサブネットに VPC エンドポイントを作成します。アプリケーションは VPC エンドポイントを使用してキャッシュに接続します。キャッシュが VPC エンドポイントを作成できない場合は、アクセス許可に問題がある可能性があります。アクセス許可に関する問題のトラブルシューティングについては、「ElastiCache Serverless クラスターの作成に関する問題を解決する方法を教えてください」を参照してください。
IAM ユーザーまたはロールに正しいアクセス許可が欠けている
IAM ユーザーまたはロールに適切なアクセス許可が欠けている場合、次のエラーメッセージが表示されることがあります。
「An error occurred (AccessDenied) when calling the CreateReplicationGroup operation: User: arn:aws:sts::xxxxxxxxx:assumed-role/Hello123 is not authorized to perform: elasticache:CreateReplicationGroup on resource: arn:aws:elasticache:ap-southeast-2:xxxxxxxxxx:replicationgroup:ROLEA because no identity-based policy allows the elasticache:CreateReplicationGroup action」
ElastiCache でカスタムマネージド IAM ポリシーを使用する場合は、次のいずれかの手順を実行します。
- IAM コンソールを使用して、iam:createServiceLinkedRole を呼び出すためのアクセス許可を有効化します。
- ElastiCache サービスリンクロールを作成します。詳細については、「サービスリンクロールの作成 (IAM)」を参照してください。
AWS アカウントのサービスクォータを増やす必要がある
アカウントには、各 AWS サービスのデフォルトクォータがあり、各クォータは使用するリージョンに固有です。
アカウントに必要なサービスクォータがない場合、次のいずれかのエラーメッセージが表示されることがあります。
- 「Cache subnet group quota exceeded.You can have at most 500 cache subnet groups in this region. (このリージョンには、最大 500 のキャッシュサブネットグループを配置できます)If you need more, please visit the Support Center and open a Service Limit Increase case」
- 「Customer node quota exceeded.You can have at most 1250 nodes in this region. (このリージョンには、最大で 1250 のノードを配置できます)If you need more, please visit the Support Center and open a Service Limit Increase case」
一部のクォータでは、増加リクエストを行えます。クォータの詳細および、クォータを増やす方法については、「ElastiCache のクォータ」を参照してください。
エンジン固有のパラメータに設定ミスがある
エンジンバージョンのパラメータグループを指定しなかった場合、次のエラーメッセージが表示されることがあります。
「An error occurred (InvalidParameterCombination) when calling the CreateReplicationGroup operation: Expected a parameter group of family redis7 but found one of family redis6.x. (想定した redis7 ファミリーのパラメータグループではなく、redis6.x ファミリーのパラメータグループが見つかりました)User has to verify that Parameter Group used has engine version that matches the cluster that is created (使用するパラメータグループのエンジンバージョンが、作成されたクラスターと一致することを確認する必要があります)」
ElastiCache クラスターを作成する際、正しいパラメータグループを使用しており、エンジンバージョンとクラスターモードタイプと一致していることを確認してください。
