Trying to track redshift Assert error

5

Since today we are having this error, the DBT/SQL was not touched I'm receiving errors in many processes with this same message. A full refresh on DBT clears it, but when the first incremental runs, it starts to fail again with the same error, "context" is not helping. I ran the query manually and had no trouble at all. It's a query that creates a table, a delete on the destination table (with a where), and inserts into it (managed by DBT that wasn't modified for more than 6 months, the query runs daily and also wasn't changed on the last months). The only thing that I think changed was the Redshift version via an auto-maintenance yesterday, but can't do a rollback to validate, or can I? I was in "current" version on maintenance, just switched to "trailing", now I'm on 1.0.38361, and can't find the changelog for that version.


20:26:44 | 
20:26:44 | 1 of 1 START incremental model xxxxxx......... [RUN]
20:26:51 | 1 of 1 ERROR creating incremental model xxxxxx [ERROR in 6.44s]
20:26:51 | 
20:26:51 | Finished running 1 incremental model in 8.55s.

Completed with 1 error and 0 warnings:

Database Error in model xxxxx (models/xxxxx.sql)
  Assert
  DETAIL:  
    -----------------------------------------------
    error:  Assert
    code:      1000
    context:   size >= 0 - size=-2, 0=0. 
    query:     62706875
    location:  tbl_trans.cpp:867
    process:   padbmaster [pid=70356]
    -----------------------------------------------
  compiled SQL at target/run/xxxxx/xxxxx.sql

Done. PASS=0 WARN=0 ERROR=1 SKIP=0 TOTAL=1

Any idea of what can be happening?

Thanks!

質問済み 2年前1324ビュー
3回答
1

Ok, it's a Redshift issue rollbacked to 1.0.38094 and everything works again

回答済み 2年前
0

Just replying to this to make sure it gets visibility from the Redshift dev team - we had a similar Assert error cropping up on queries that previously ran flawlessly, and rolling back to 1.0.38094 fixed the issue for us.

回答済み 2年前
  • I accidentally let our cluster update to latest, and the assert error returned, I've reworked my query slightly, and seem to have it working now. I think the change that got it back was removing a ROUND (possibly a ROUND interacting with a LEAST).

0

Hi, this issue is back and now without the rollback button, Any ideas will be VERY welcome. Thanks

回答済み 2年前

ログインしていません。 ログイン 回答を投稿する。

優れた回答とは、質問に明確に答え、建設的なフィードバックを提供し、質問者の専門分野におけるスキルの向上を促すものです。

質問に答えるためのガイドライン

関連するコンテンツ