スキップしてコンテンツを表示

Docker container fails to start

0

Someone can help me on this issue:

CannotStartContainerError: ResourceInitializationError: failed to create new container runtime task: failed to create shim task: failed to create init process I/O: 1 error occurred: * failed to start binary process: fork/exec /sbin/shim-logger-wrapper: argument list too long : unknown

the container is pulled from ECR. i'am trying to deploy a service on ECS.

質問済み 3年前2156ビュー

1回答
0

This is related to a command in your Dockerfile or docker build file in your ECR that it is expanding as it's executing.

Try pulling image locally and debug it. Here's documentation about to pull image from ECR into Docker on your local machine: https://docs.aws.amazon.com/AmazonECR/latest/userguide/docker-pull-ecr-image.html

AWS

回答済み 3年前

ログインしていません。 ログイン 回答を投稿する。

優れた回答とは、質問に明確に答え、建設的なフィードバックを提供し、質問者の専門分野におけるスキルの向上を促すものです。

関連するコンテンツ