Athenaと接続するS3のバージョンについて

1

Athenaと接続するS3のバージョンについて、条件、制約、注意事項などありますでしょうか? 条件等とは例えば以下の内容のような注意事項あれば athenaとS3の構築をおこなおうとしていますが 注意いしたいと思います。

質問1 ・Athenaのバージョンは接続するS3のバージョンと同じまたはそれ以上とする必要がありますでしょうか

質問2 ・Athenaのバージョンは接続するS3のバージョンは同じでなければならいでしょうか?

質問3 ・Athenaのバージョンは、S3より低くても問題ないでしょうか?

質問4 ・・Athenaのバージョンは接続するS3のバージョンについて注意点はありますでしょうか?

質問済み 9ヶ月前270ビュー
2回答
0

特に注意事項は無いです。
以下のドキュメントの通り設定いただけば使用可能です。
https://docs.aws.amazon.com/ja_jp/athena/latest/ug/getting-started.html

ちなみにS3内のデータをクエリするにはGlueも必要なので以下のドキュメントをご確認ください。
https://docs.aws.amazon.com/ja_jp/athena/latest/ug/glue-athena.html

ちなみにバージョンとおっしゃっているのは何のバージョンのことを指していますか?

profile picture
エキスパート
回答済み 9ヶ月前
0

情報が不足していて申し訳ありません。バ-ジョンについて質問させていただいたのは、AWSSDKのAthena及びS3の開発パッケージのバ-ジョンのことでした。 VisualStudioで、開発する時、「NuGet パッケージマネージャー>ソリューションの NuGet パッケージの管理のところで、AWSSDK AthenaとAWSSDK S3のそれぞれのパッケージのバージョンを選択して開発した時に、AWSSDK Athenaのバ-ジョンをAWSSDK S3のバ-ジョンより低いときにエラーとなったもので、AWSSDK AthenaとAWSSDK S3のそれぞれのパッケージ間でバージョンの組み合わせで条件があるのではなかろうかという点で質問させていただきました。実際のAthenaとS3のサービスを構築する時は、各々のバージョンについての注意点はない点は理解しておりました。誠に申し訳ありません。

回答済み 9ヶ月前

ログインしていません。 ログイン 回答を投稿する。

優れた回答とは、質問に明確に答え、建設的なフィードバックを提供し、質問者の専門分野におけるスキルの向上を促すものです。

質問に答えるためのガイドライン

関連するコンテンツ