AWS re:Postを使用することにより、以下に同意したことになります 利用規約

How to Enable Fleet Autoscaling in Gamelift?

0

So we have a game that we are soon going to roll out for beta testing and would like to know how to enable the autoscaling feature? Right now, Under scaling section for the fleet in Frankfurt region, I am shown that I can have only 1 server and when I enable the autoscaling feature, the desired number of servers under scaling limits turns to 0 and no player session is able to be activated throwing FleetExceptionError. So as a team planning to launch a battle royale game, for us we don't mind the max number of services we need as we expect exponential growth in players once we roll out the game, But this available servers=0 is a concern we would like to know how to address. Any help will be much appreciated.

Enter image description here

1回答
0

Hi,

From the screenshot posted above, you should first uncheck the "Disable all scaling policies" to enable auto-scaling. If you expect to have many sessions, you should crank up the max number of instances. GameLift cannot set the number of instances outside the min/max range, regardless of whether the number of instances is set manually or through auto-scaling: https://docs.aws.amazon.com/gamelift/latest/apireference/API_UpdateFleetCapacity.html

Hope that helps.

回答済み 10日前
  • Hi, When I uncheck the Disable all scaling policies, I am getting Fleet Exception Error. Also how to set more than 1 instances through autoscaling when the available server instances for my our aws account in frankfurt is 1 for the specific instance type we are choosing?

ログインしていません。 ログイン 回答を投稿する。

優れた回答とは、質問に明確に答え、建設的なフィードバックを提供し、質問者の専門分野におけるスキルの向上を促すものです。

質問に答えるためのガイドライン