AWS re:Postを使用することにより、以下に同意したことになります 利用規約

タグ付けされた質問 Amazon EC2

コンテンツの言語: 日本語

並べ替え 最新

以下に記載されている質問と回答を閲覧したり、フィルタリングして並べ替えて結果を絞り込んだりできます。

EC2にSSHでログインまではできるものの、反応しなくなってしまいました

いつもお世話になっております。 インスタンスIDは「i-04258ea30cf497bad」です。 EC2にログインしてPHP周りの設定を行っていたところ、 デフォルトユーザー「ec2-user」の「.bashrc」「.bash_profile」を設定したところ、 表題の状態になってしまいました。 MacのターミナルからSSHを使って鍵認証でログインまではできる(EC2の表示はされる)のですが、 ログイン後は入力を一切受け付けず、しばらくすると接続が解除されてしまいます。 Webサーバー(Apache)もストップしてしまい、なんとかWebサーバーは再起動したいのですが、 他の方法も使用できず困っております。 ・EC2 Instance Connect →AWSのコンソールより接続を試みたところ、何度やっても接続できませんでした。 ・AWS Systems Managerのセッションマネージャー EC2インスタンスで設定を行っていなかったため、使用できません。 rootとec2-user以外にFTPからアクセスできるアカウントがあり、 そちらでFTP接続のみ正常に行えております。 取り急ぎWebサーバーの復旧だけでもと考えているのですが、 何か良い方法がございましたらご教示いただけますと幸いです。 よろしくお願いいたします。
1
回答
0
投票
6
ビュー
Koheii
質問済み 3年前

メール送信解除申請を受理されて以降も送信エラーが頻発している

メール送信制限に関するご質問です。 PrivateSubnet内のEC2インスタンスからNAT Gatewayを通して外部メール送信を行いたく、メール送信制限の解除を行い承認されたメール(制限解除をおこなった)が届きました。 しかし、その後1か月以上経過していますが、メール送信できない状況が続いていたため、10/17より再申請を行っていますが、うまく状況を理解していただけないのか状況が変わらず好転いたしません。 こちらの調査では、EC2インスタンスから外部メールサーバへSMTP接続させたときに「SYN-SENT」状態で通信がとまっていることを確認していますので、外部へのPort25のアウトバウンド通信がネットワーク的にブロックされているように思えるのですが、申請手続きの不備があったでしょうか?? 以下、詳細を記載いたしますのでご確認宜しくお願いいたします。 --- 9/19 メール送信制限解除申請を行い、同日承認されたとのメールをいただく。 (We've reviewed and approved your request for the removal of the EC2 e-mail sending limitations on your Amazon Web Services account.) 9/20~10/17 その後も、メールが外部へ送信できない状況が続くため下記のとおり調査を実施。 〇/var/log/maillog --- Oct 17 XX:XX:XX XXXXX postfix/smtp\[11005]: connect to alt4.gmail-smtp-in.l.google.com\[173.194.66.26]:25: Connection timed out --- $ telnet XXX.XXX.XXX.XXX 25 Trying XXX.XXX.XXX.XXX... 〇応答が返ってこない状態でコネクション状態を確認。 --- SYN-SENT 0 1 AAA.AAA.AAA.AAA:41094 XXX.XXX.XXX.XXX:25 --- ※SYN-SENTでとまっていることからネットワーク通信的にブロックされていると思われる。 〇別EC2インスタンスからのSMTP疎通確認 インスタンス起動直後から、3回目まではSMTP接続に成功するが4回目以降で上記と同じく「SYN-SENT」状態で応答がなくなる。 また、起動直後から現在までPort25以外での外部向け通信は支障なくできることを確認。 10/17 本状況と調査内容をまとめた文書を添えて再申請を行うも、DNS逆引き設定を行うような案内回答をいただく。 ※DNS逆引き設定はAnti-SPAMのためのもので「SYN-SENT」でネットワーク的に通信できない状況を改善するものではないのでは?? 以上。
1
回答
0
投票
2
ビュー
ymasa
質問済み 3年前

ApplicationLoadBalancerのヘルスチェックがunhealthyのまま改善しない

お世話になります。 表題の件について、ご協力を仰ぐことができればと思い、スレッドを立てさせていただきます。 現在、ドメインのSSL化のためにアプリケーションロードバランサーを使い、 該当インスタンスに接続しています。 しかし、ロードバランサーのヘルスチェックがいつまでもunhealthyのままになってしまっています。 しかしながら、該当ドメインをブラウザで接続すると、きちんと画面は表示され、 速度が極端に遅いなどの症状も見られません。 ロードバランサーを新しく立て直すなどの対策もしましたが、効果がありませんでした…。 根本的に、VPCやサブネット、サブドメインの設定か、何かが間違っている可能性が高いのですが、 どのようにすれば解決するか全く見立てがつきません…。 以下、まずはお出しする情報です。※「この項目を教えて」とご指摘いただければ、開示できる範囲でお出しします。 -------------------------------- ■Route 53 ふたつのサブドメインを同じロードバランサーに向けて指定。 ■ApplicationLoadBalancer ap-northeast-1a ap-northeast-1c ふたつのAZに配置されたサブネットに向けています。 ただし、必要とするインスタンスはひとつしかないので、ap-northeast-1c側のサブネットの中は空っぽです。 リスナーはHTTP(80)・HTTPS(443)両方を開き、証明書は間違いなく合致するものを選択しております。 ■TargetGroup ap-northeast-1a内にあるインスタンスに向けており、ポートはHTTP(80)。 ヘルスチェックは /index.html に設定、ポートはトラフィックポート、 正常のしきい値は3、非正常のしきい値は2、タイムアウト20秒、間隔30秒、成功コード200. ■インスタンス Apacheでふたつのサブドメインを受けるようにマルチドメイン化。 どちらのサブドメインのWebルート上にもindex.htmlは設置しており、ブラウザで表示確認済み。 片方のサブドメインはTomcatのディレクトリに転送しています。 -------------------------------- そもそもブラウザできちんと表示されているのに、どうしてヘルスチェックだけ通らないのか 状況がまったく分からず、混乱しております。 みなさまのお知恵をお借りできればと思います。よろしくお願いいたします。 【追記】 index.htmlに自分でブラウザよりアクセスして、Apacheのaccess.logを確認したところ、きちんと200を返しています。が、ロードバランサーのヘルスチェックのアクセスはログが出ていますが、404を返しています。 Edited by: imagamuk on Feb 5, 2019 9:37 PM
1
回答
0
投票
3
ビュー
質問済み 4年前