Skip to content

How do I troubleshoot Amazon EC2 instance launch failures caused by AMI issues?

4 minute read
0

I want to troubleshoot my Amazon Machine Image (AMI) that fails to launch an Amazon Elastic Compute Cloud (Amazon EC2) instance.

Short description

When you launch an EC2 instance from an AMI, you might receive one of the following error messages:

  • "Error launching AMI: In order to use the AWS Marketplace product you need to accept the terms and subscribe."
  • "The instance configuration for this AWS Marketplace product is not supported. Please see the AWS Marketplace site for more information about supported instance types, regions, and operating systems"
  • "This version has been removed and is no longer available to new customers."

Or, your instance might immediately stop after you launch it. This issue typically occurs when you launch an instance from a shared AMI that has encrypted Amazon Elastic Block Store (Amazon EBS) volumes.

Resolution

Troubleshoot the "you need to accept the terms and subscribe" error

You can create new AMIs or launch instances from the instances that you created with an AWS Marketplace AMI. AWS accounts that you share these AMIs with must subscribe to the AWS Marketplace AMI. If the shared account doesn't subscribe to the original AWS Marketplace AMI, then you can't launch an instance from the new AMI. You also can't attach an Amazon EBS volume that you created from a snapshot of the AMI.

To resolve this issue, open the link in the error message to subscribe the account to the AMI. Then, accept the terms of the AMI. Or, use the AWS Marketplace console to subscribe to the AMI.

Troubleshoot the "configuration for this AWS Marketplace product is not supported" error

Vendors can restrict AWS Marketplace AMIs to allow only specific instance configurations and Regions. If you try to launch an unsupported configuration, then you receive the "configuration for this AWS Marketplace product is not supported" error message.

To resolve this error, check the following:

Confirm the instance type is supported

Check the AWS Marketplace product page for the AMI for information about supported instance types. Confirm that you use a supported instance type.

Confirm the Region is available for the product

AWS Marketplace products have a seller-controlled regional availability setting. Sellers explicitly configure which AWS Regions their product versions are available in. You can receive this error even if you have an active subscription and the AMI appears in EC2 AMI search results.

Note: The AMI might appear in EC2 console search results even if the seller hasn't activated the Region for the product. AMI visibility in EC2 doesn't confirm regional availability for the AWS Marketplace product.

If you confirmed the instance type is supported but you still receive the error, then the product might not be available in your target Region. Contact the seller's support team through the AWS Marketplace product page to request that they activate the product in your Region. Only the seller can resolve this issue.

For more information, see Managing AMI-based product availability by AWS Region and country.

Troubleshoot the "version has been removed" error

The "version has been removed" error typically occurs when the vendor deprecated the AMI. It's a best practice to migrate your instance to the latest version of the AMI.

For additional product information, contact the vendor's support team through the AWS Marketplace, or email their support address.

Troubleshoot encrypted EBS volume issues

If your instance immediately stops after launch from a shared AMI that has encrypted EBS volumes, then the AWS Identity and Access Management (IAM) user or role might lack the required AWS Key Management Service (AWS KMS) permissions. For step-by-step resolution, see How do I resolve launch or start failures for an Amazon EC2 instance with encrypted Amazon EBS volumes?.

AWS OFFICIALUpdated 8 days ago