Amazon Elastic Container Service(Amazon ECS) 작업을 실행하고 싶은데 AccessDenied 오류가 발생합니다.
간략한 설명
AccessDenied 오류는 Amazon ECS 리소스가 사용하는 AWS Identity and Access Management(IAM) 역할에 AWS 리소스에서 작업을 실행하는 데 필요한 권한이 없을 때 발생합니다. 이 문제를 해결하려면 누락된 권한을 IAM 역할에 추가하십시오.
해결 방법
IAM 역할에 필요한 권한이 없는지 확인하려면 서비스 이벤트 메시지와 Amazon ECS 작업 로그에서 중지된 작업 오류를 확인하십시오.
Amazon ECS 리소스의 IAM 역할에 필요한 권한이 없는 경우 다음과 같은 오류 메시지가 표시됩니다.
"User: arn:aws:iam::123456789012:rolename is not authorized to perform: ecs:action on resource: arn:aws:ecs:region:123456789012:resource-type/resource-name"
위의 예제 오류 메시지에서 arn:aws:iam::123456789012:rolename은 IAM 역할, ecs:action은 누락된 권한, arn:aws:ecs:region:123456789012:resource-type/resource-name은 영향을 받은 리소스입니다. 권한 정책에서 사용하려면 이러한 값을 기록해 두십시오.
Amazon ECS 관리형 정책 사용
Amazon ECS에 대한 IAM 역할을 사용할 때는 Amazon ECS 관리형 정책을 사용하는 것이 좋습니다. Amazon ECS 관리형 정책에는 가장 일반적인 필수 권한이 포함됩니다.
Amazon ECS 관리형 정책을 사용하려면 다음 단계를 완료하십시오.
- IAM 콘솔을 엽니다.
- 탐색 창에서 역할을 선택합니다.
- 영향을 받는 IAM 역할을 선택합니다.
- 권한 추가를 선택한 다음, 직접 정책 연결을 선택합니다.
- 검색 창에서 IAM 역할에 필요한 권한을 기반으로 관리형 정책을 입력하고 선택합니다.
- 다음을 선택하고 권한 추가를 선택합니다.
- 권한을 테스트하려면 실패한 작업을 실행합니다.
인라인 정책 생성
사용자 지정 권한을 설정하려면 권한 요구 사항을 기반으로 인라인 정책을 생성한 다음, 해당 정책을 Amazon ECS IAM 역할에 연결합니다.
관련 정보
Amazon Elastic Container Service의 Identity and Access Management
다른 AWS 계정에서 IAM 역할을 맡도록 Amazon ECS 작업을 구성하려면 어떻게 해야 합니까?