AWS Builder Center: Learn, Build and Connect with builders in the AWS community
AWS Builder Center is the official home for builders on AWS. Share and read what others are working on, follow people who inspire you, explore training and workshops, and find tools to support what you're building.
OpenSearch Service의 Kibana 또는 OpenSearch 대시보드 오류를 해결하려면 어떻게 해야 합니까?
Amazon OpenSearch Service에서 표시되는 Kibana 또는 OpenSearch 대시보드 오류를 해결하고 싶습니다.
해결 방법
기본 인프라 또는 구성 문제가 있는 경우 다음 오류 메시지 중 하나가 표시됩니다.
"OpenSearch Dashboards/Kibana server is not ready yet"
"OpenSearch Dashboards/Kibana did not load properly"
"OpenSearch Dashboards/Kibana did not load properly. Check the server output for more information."
이러한 문제를 해결하고 서버가 제대로 작동하는지 확인하려면 다음 설정을 확인합니다.
- CPU 사용률이 80%를 초과하지 않는지 확인합니다.
- Java 가상 머신(JVM) 메모리 압력 지표가 75%를 초과하지 않는지 확인합니다.
- 표시되는 ClusterBlockException 및 IndexCreateBlockException 오류를 해결합니다.
- OpenSearch Service 도메인의 스토리지 공간이 부족한지 확인합니다.
- 샤드를 노드 전체에 균등하게 분배합니다.
- 샤드가 각 노드의 기본 임계값인 1,000을 초과하지 않는지 확인합니다. 노드의 샤드 수를 줄이려면 불필요한 인덱스를 삭제하거나 클러스터에 노드를 더 추가하십시오. 인덱스를 삭제하려면 OpenSearch 웹 사이트에서 Delete index API를 참조하십시오. 샤드 모범 사례에 대한 자세한 내용은 샤드 수 선택을 참조하십시오.
- 실패한 노드를 확인합니다.
- 클러스터에 과도한 부하를 야기하는 대량 쿼리를 사용하지 마십시오. 대량 쿼리를 사용하여 인덱싱 성능을 개선해야 하는 경우에는 소량 크기부터 시작하여 점진적으로 늘리십시오. 자세한 내용은 Elastic 웹 사이트에서 Using and sizing bulk requests를 참조하십시오.
- OpenSearch Service 도메인의 리소스 기반 정책에서 AWS Identity and Access Management(IAM) 사용자와 역할이 서비스와 상호 작용하도록 허용하는지 확인합니다.
참고: IP 기반 정책을 사용할 수도 있습니다. ID 기반 정책을 사용하여 Kibana 대시보드 또는 OpenSearch 대시보드에 대한 액세스를 구성할 수는 없습니다.
여전히 문제가 발생하는 경우 다음 문제 해결 단계를 사용하여 문제를 해결하십시오.
"Http request timed out" 오류 또는 VPC 액세스 문제 해결
OpenSearch Service 클러스터가 가상 프라이빗 클라우드(VPC)에 있는 경우 "{"Message":"Http request timed out connecting"}" 오류 메시지가 표시될 수 있습니다. 이 문제는 네트워크 연결 문제로 인해 Kibana 또는 OpenSearch 대시보드와의 연결이 차단될 때 발생합니다.
이 오류를 해결하려면 다음 작업을 수행하십시오.
- VPC의 보안 그룹이 클라이언트 IP 주소에서 포트 443으로 들어오는 인바운드 트래픽을 허용하는지 확인합니다.
- 클라이언트가 OpenSearch Service 클러스터와 다른 VPC에 있는 경우 클라이언트와 OpenSearch Service 서브넷을 올바르게 구성했는지 확인합니다. 예를 들어 VPC 엔드포인트, VPC 피어링 연결, VPN 또는 AWS Direct Connect 연결을 확인합니다.
- 서브넷 라우팅 테이블에 OpenSearch Service 도메인에 액세스하는 데 필요한 경로가 있는지 확인합니다.
자세한 내용은 VPC 내에서 OpenSearch Service 도메인 시작을 참조하십시오.
"User: anonymous is not authorized to perform" 오류 해결
세분화된 액세스 제어를 활성화한 후 SAML 2.0 인증을 사용하면 다음과 같은 오류 메시지가 표시될 수 있습니다.
"{"Message":"User: anonymous is not authorized to perform: es:ESHttpGet because no resource-based policy allows the es:ESHttpGet action"}"
이 오류를 해결하려면 다음 작업을 수행하십시오.
- 리소스 기반 정책에 인증된 SAML 2.0 사용자에게 필요한 권한이 포함되어 있는지 확인합니다.
- 백엔드 역할을 SAML 2.0 속성에 올바르게 매핑했는지 확인합니다.
SAML 2.0, Amazon Cognito 또는 IAM Identity Center 통합 문제 해결
다음 작업을 수행하십시오.
- ID 제공업체(idP)와 OpenSearch Service 모두에서 SAML 2.0 메타데이터를 올바르게 구성했는지 확인합니다.
- Amazon Cognito 사용자 풀과 ID 풀을 올바르게 설정하고 OpenSearch Service 도메인에 연결했는지 확인합니다. 문제를 해결하려면 일반적인 구성 문제를 참조하십시오.
- Amazon Cognito 인증에 필요한 IAM 역할 및 권한을 구성했는지 확인합니다.
사용자 지정 프록시 문제 해결
사용자 지정 프록시를 사용할 때 문제가 발생하면 다음 조치를 취하십시오.
- 프록시 없이 엔드포인트 URL을 통해 Kibana 또는 OpenSearch 대시보드에 액세스하여 프록시 구성이 액세스를 차단하는지 확인합니다.
- 프록시가 OpenSearch Service 도메인에 요청을 전달하는지 확인합니다.
- 프록시가 필요한 헤더를 보관하는지 확인합니다. NGINX 프록시를 구성하는 방법에 대한 자세한 내용은 Amazon Cognito 인증을 사용하지 않는 VPC 외부에서 NGINX 프록시를 사용하여 Kibana 또는 OpenSearch 대시보드에 액세스하려면 어떻게 해야 합니까?를 참조하십시오.
프록시 구성 샘플은 VPC 내 OpenSearch Service 도메인에 대한 SAML ID 페더레이션 구축을 참조하십시오.
VPC에서의 Amazon Cognito 인증은 NGINX 프록시를 사용하여 VPC 외부에서 Amazon Cognito 인증을 통해 OpenSearch 대시보드에 액세스하려면 어떻게 해야 합니까?를 참조하십시오.
만료된 인증서 문제 해결
프록시 엔드포인트의 인증서가 만료되면 액세스 문제가 발생할 수 있습니다.
문제를 해결하려면 다음 조치를 취하십시오.
- 프록시 설정에서 사용 중인 인증서의 만료 날짜를 확인합니다.
- 만료된 인증서를 갱신하고 프록시 구성에서 업데이트합니다.
- 인증서가 만료되기 전에 알림을 받을 수 있도록 인증서를 모니터링합니다.
"exceeded the number of permissible concurrent requests" 오류 또는 스로틀링된 리소스 문제 해결
노드에서 서로 다른 IAM 자격 증명을 사용하여 서명된 요청을 너무 많이 수신하면 다음과 같은 오류 메시지가 표시됩니다.
"You have exceeded the number of permissible concurrent requests with unique IAM Identities"
이 오류를 해결하려면 다음 작업을 수행하십시오.
- IAM 역할 또는 사용자를 통합하여 요청에 사용되는 다양한 자격 증명을 줄입니다.
- 클러스터에 노드를 추가하여 노드 수준 스로틀링 임계값을 높입니다.
- 클라이언트 애플리케이션에서 재시도 로직을 구현합니다.
- 요청량을 점차 늘립니다.
- 여러 자격 증명을 사용한 대량 작업을 방지합니다.
블루/그린 배포 시 인덱스 및 마이그레이션 문제 해결
블루/그린 배포 중에 다음과 같은 이유로 문제가 발생할 수 있습니다.
- Kibana 또는 OpenSearch 대시보드 인덱스에 영향을 주는 와일드카드 인덱스 패턴 템플릿 충돌
- Kibana 또는 OpenSearch 대시보드 인덱스의 손상된 문서
이러한 문제를 해결하려면 다음 명령을 실행하여 인덱스 템플릿이 충돌하는지 확인합니다.
GET _cat/templates
출력 예시:
GET _cat/templates?v name index_patterns order version composed_of my-index-template [*] 0 GET _template/my-index-template { "my-index-template": { "order": 0, "index_patterns": [ "*" ], "settings": { <index-settings> }, "mappings": { <index-mappings> }, "aliases": { <index-alias> } } }
자세한 내용은 OpenSearch 웹 사이트의 CAT templates API를 참조하십시오.
**"index_patterns": "*"**는 모든 인덱스를 포함하므로 인덱스 템플릿에는 사용하지 않는 것이 좋습니다. 대신 다음 명령을 실행하여 특정 접두사가 있는 인덱스만 포함하도록 인덱스 템플릿을 수정합니다.
PUT _template/my-index-template { "index_patterns": ["your-index-prefix-*"], "settings": { index-settings }, "mappings": { index-mappings }, "aliases": { index-alias } }
참고: your-index-prefix-*를 인덱스 접두사로, index-settings를 인덱스 설정으로, index-mappings를 인덱스 매핑으로, index-alias를 인덱스 별칭으로 바꾸십시오. 자세한 내용은 OpenSearch 웹 사이트의 Put template을 참조하십시오.
필요한 경우 Kibana 또는 OpenSearch 대시보드 인덱스를 삭제하십시오. 자세한 내용은 OpenSearch 웹 사이트에서 Delete index API를 참조하십시오. 그런 다음 수동 스냅샷에서 인덱스를 복원합니다.
단일 노드 장애 해결
개별 노드 충돌로 인해 Kibana 또는 OpenSearch 대시보드에 대한 액세스 권한이 손실될 수 있습니다.
이 오류를 해결하려면 다음 작업을 수행하십시오.
- 영향을 받는 노드에 대한 Amazon CloudWatch의 클러스터 지표를 확인하여 노드가 언제 비정상으로 변하는지 파악합니다.
Elasticsearch 버전 7.10 및 이전 버전의 경우 KibanaHealthyNodes를 확인합니다.
OpenSearch 버전 1.x 이상에서는 OpenSearchDashboardsHealthyNodes를 확인합니다. - 중복성 개선을 위해 클러스터의 노드 수를 늘리십시오.
단일 노드가 있는 경우 다음 단계를 완료하여 자동 스냅샷에서 .kibana* 인덱스를 복원하십시오.
- 리포지토리에서 사용할 수 있는 자동 스냅샷을 나열하려면 다음 명령을 실행합니다.
참고: repository는 암호화되지 않은 도메인의 경우 cs-automated로 바꾸고, 암호화된 도메인의 경우 cs-automated-enc로 바꾸십시오.GET /_cat/snapshots/repository - 특정 스냅샷의 인덱스 목록을 보려면 다음 명령을 실행합니다.
참고: repo-name을 리포지토리 이름으로 바꾸고 snapshot-id를 스냅샷 ID로 바꾸십시오.GET _snapshot/repo-name/snapshot-id?pretty - .kibana* 인덱스를 복원하려면 다음 명령을 실행합니다.
참고: repo-name을 리포지토리 이름으로 바꾸고 snapshot-id를 스냅샷 ID로 바꾸십시오. 인덱스를 복원하려고 할 때 권한 문제가 발생하면 AWS Support 사례를 여십시오. Kibana와 OpenSearch 대시보드는 모두 kibana* 인덱스를 사용합니다.POST _snapshot/repo-name/snapshot-id { "indices": ".kibana*" }
자세한 내용은 OpenSearch Service 노드가 충돌한 이유는 무엇입니까?를 참조하십시오.
"OpenSearch Security not initialized" 오류 해결
보안 초기화가 실패하면 "OpenSearchSecurityException[OpenSearch Security not initialized for __PATH__]" 오류 메시지가 표시됩니다.
도메인의 보안 플러그인이 초기화되었는지 확인하려면 브라우저에서 https://kibana-dashboards-url/api/status?pretty URL을 여십시오.
참고: kibana-dashboards-url을 대시보드 URL로 바꾸십시오.
출력 예시:
... Redacted ... { "id": "plugin:securityDashboards@2.15.0", "message": "All dependencies are available", "since": "2025-08-22T11:23:58.243Z", "state": "green", "icon": "success", "uiColor": "secondary" }, ... Redacted ...
출력에서 state가 green이 아닌 경우 URL을 다시 여십시오. 그래도 state가 green이 아니거나 URL을 열 때마다 바뀌면 보안 플러그인이 제대로 초기화되지 않은 것입니다. 이 문제를 해결하려면 AWS Support 사례를 여십시오.
"500" 오류 해결
CPU 사용률 또는 JVM 메모리 압력이 높으면 다음과 같은 오류 메시지가 표시될 수 있습니다.
"{"statusCode":500,"error":"Internal Server Error","message":"An internal server error occurred."}"
CPU 사용률과 JVM 메모리 압력이 너무 높지 않은지 확인합니다. 발생한 문제에 대한 자세한 내용을 보려면 OpenSearch 로그에서 오류나 예외에 대한 자세한 내용을 확인하십시오. CPU 사용률과 JVM 메모리 압력이 낮은데도 여전히 "500 오류가 표시되면 AWS Support 사례를 여십시오.
정보 누락 문제 해결
다음 오류 메시지 중 하나가 표시될 수 있습니다.
- "OpenSearch Dashboards/Kibana blank page"
- "Unable to see any data on OpenSearch Dashboards/Kibana Visualization or Dashboards"
대시보드의 검색 페이지에 누락된 정보가 있는 경우 다음 단계를 완료하여 문서에 타임스탬프 필드가 있는지 확인합니다.
- Kibana 또는 OpenSearch 대시보드를 엽니다.
- 대시보드 관리를 선택합니다.
- 인덱스 패턴을 선택합니다.
- 인덱스 패턴을 선택합니다.
- 시간 필드에서 타임스탬프를 선택합니다.
문서의 타임스탬프 필드를 구성한 후 다음 구성을 확인합니다.
- 타임스탬프 필드를 올바르게 구성했는지 확인하려면 Dev Tools 콘솔에서 다음 명령을 실행합니다.
참고: your-index를 인덱스 이름으로 바꾸십시오. 출력에서 timestamp가 date로 설정되었는지 확인합니다. date로 설정되지 않은 경우 _reindex API를 사용하여 타임스탬프를 설정합니다. 자세한 내용은 OpenSearch 웹 사이트의 Reindex data를 참조하십시오.GET your-index/_mappings?pretty - 검색 페이지에서 인덱스 패턴에 맞는 시간 범위를 선택했는지 확인합니다.
- 세분화된 액세스 제어를 활성화한 경우 백엔드 역할에 데이터를 볼 수 있는 권한이 있는지 확인합니다.
노드의 상태 모니터링
Kibana 및 OpenSearch 대시보드는 OpenSearch Service 노드와 동일한 CPUUtilization 및 JVMMemoryPressure 리소스를 사용합니다. 노드의 상태를 확인하려면 KibanaHealthyNodes 또는 OpenSearchDashboardsHealthyNodes 지표를 검토하십시오. 또는 OpenSearch Service 콘솔에서 도메인의 클러스터 상태 탭에서 Kibana 상태를 확인합니다.
상태 지표는 데이터 노드에서 실행되는 Kibana 또는 OpenSearch 대시보드 플러그인의 다음 상태 중 하나를 보여줍니다.
- 녹색은 Kibana 또는 OpenSearch 대시보드가 모든 데이터 노드에서 실행되고 있으며 알려진 문제가 없음을 나타냅니다.
- 노란색은 Kibana 또는 OpenSearch 대시보드가 데이터 노드의 전부가 아닌 일부에서 실행되고 있음을 나타냅니다. 이 상태에서는 Kibana 또는 OpenSearch 대시보드가 느리게 실행됩니다.
- 빨간색은 Kibana 또는 OpenSearch 대시보드가 모든 노드에서 다운되었음을 나타냅니다. 이 상태에서는 Kibana 또는 OpenSearch 대시보드는 실행되지 않으며 사용자가 액세스할 수 없습니다.
- 언어
- 한국어

관련 콘텐츠
질문됨 3년 전