내용으로 건너뛰기

Amazon Q Business를 사용할 때 나타나는 “Server stopped responding” 오류 문제를 해결하려면 어떻게 해야 합니까?

2분 분량
0

Amazon Q Business를 사용하려고 할 때 나타나는 “Server stopped responding” 오류 문제를 해결하고 싶습니다.

해결 방법

Amazon Q Business에서 필요한 네트워크 연결을 설정할 수 없는 경우 “Server stopped responding” 오류가 발생합니다. Amazon Q Business는 wss://qbusiness.{region}.api.aws:8443/chat과 같은 엔드포인트와의 안전한 통신을 유지하기 위해 포트 8443을 통한 WebSocket 기술을 사용합니다. 웹 경험이 작동하려면 포트 8443이 열려 있어야 하며 네트워크에서 액세스할 수 있어야 합니다.

포트 접근성으로 인해 문제가 발생하는지 확인하려면 연결을 체계적으로 테스트하십시오.

참고: 네트워크에서 VPN 또는 방화벽을 사용하는 경우 VPN 또는 방화벽을 활성화하고 비활성화한 상태에서 연결을 테스트해야 합니다.

WebSocket 연결 테스트

macOS 또는 Linux의 경우 터미널을 사용하여 다음 명령을 실행합니다.

nc -v qbusiness.us-east-1.api.aws 8443

성공적인 연결의 예:

Connection to qbusiness.us-east-1.api.aws port 8443 [tcp/pcsync-https] succeeded

Windows의 경우 Windows PowerShell을 사용하여 다음 명령을 실행합니다.

Test-NetConnection -ComputerName qbusiness.us-east-1.api.aws -Port 8443

성공적인 연결의 예:

ComputerName     : qbusiness.us-east-1.api.aws
RemoteAddress    : 34.192.X.X
RemotePort       : 8443
InterfaceAlias   : Wi-Fi
SourceAddress    : 10.0.X.X
TcpTestSucceeded : True

-또는-

Pie.host 웹사이트에서 WebSocket 테스터를 사용하여 연결을 테스트합니다. 엔드포인트를 입력한 다음 Connect(연결)를 선택합니다.

네트워크 테스트에 성공하면 출력에 Connection Established(연결 수립)가 표시됩니다. 클라이언트 컴퓨터가 포트 8443의 엔드포인트에 성공적으로 연결할 수 있음을 확인하는 Connection closed(연결 종료) 메시지가 표시될 수도 있습니다.

테스트가 실패할 경우 포트 8443이 열려 있고 액세스할 수 있는지 확인합니다. 네트워크의 VPN, 가상 프라이빗 클라우드(VPC) 또는 방화벽 정책의 설정을 업데이트합니다. 필요한 설정에 액세스할 수 없는 경우 네트워크 관리자에게 문의하여 도움을 받으십시오.

포트 테스트에 성공했지만 여전히 오류 메시지가 표시되면 WebSocket 연결이 차단되었을 수 있습니다.

오류의 원인을 확인하려면 다음 단계를 완료하십시오.

  1. F12 키를 눌러 브라우저의 네트워크 콘솔을 엽니다.
  2. Amazon Q Business 애플리케이션에서 요청을 합니다.
  3. 콘솔 로그에서 WebSocket 연결 오류를 검토합니다.

차단된 WebSocket 연결에는 다음과 유사한 오류 메시지가 표시됩니다.

"WebSocket connection to 'wss://qbusiness.us-east-1.api.aws:8443/chat?X-Amz-Algorithm=AWS4-HMAC-SHA256&X-Amz-Credential=XXXXXXXXXC2MH5KBVFMS%2F20241231%2Fus-east-1%2Fqbusiness%2Faws4_request&X-Amz-Date=20241231T151549Z&X-Amz-Expires=900&X-Amz-failed'"

위 메시지가 표시되면 네트워크 관리자에게 문의하여 네트워크 연결 차단을 해제하십시오.

관련 정보

Amazon Q Business 웹 경험 사용

AWS 공식업데이트됨 일 년 전
댓글 없음