Amazon OpenSearch Service 도메인을 Amazon Quick Sight에 연결하려고 하면 오류가 표시됩니다.
해결 방법
Quick Sight를 OpenSearch Service 도메인에 연결하기 전에 도메인이 Quick Sight와 동일한 AWS 리전 및 AWS 계정에 있는지 확인하십시오.
참고: OpenSearch Service는 OpenSearch 엔진 버전 1.3 이상 또는 레거시 Elasticsearch 엔진 버전 7.7~7.10을 지원하지 않습니다.
사용 사례에 맞는 해결 방법을 수행하십시오.
지원되지 않는 엔진 버전 오류
OpenSearch Service 도메인에 연결할 때 다음 오류가 발생할 수 있습니다.
"Your database uses an unsupported engine version. Please review supported versions."
이 오류는 OpenSearch Service 도메인에서 호환성 모드가 활성화되지 않은 경우에 발생합니다. OpenSearch 버전 1.0에는 호환성 모드 활성화 도메인 설정이 포함되어 있습니다. 특정 OpenSearch Service 클라이언트와 플러그인은 연결하기 전에 클러스터 버전을 확인합니다. 호환성 모드는 이러한 클라이언트가 계속 작동할 수 있도록 OpenSearch Service가 버전을 7.10으로 보고하도록 설정합니다. 호환성 모드가 활성화되면 Quick Sight는 올바른 버전을 식별하고 연결을 설정합니다.
호환성 모드를 활성화하려면 다음 명령을 실행하십시오.
PUT /_cluster/settings{
"persistent": {
"compatibility.override_main_response_version": true
}
}
Cursor not activated or can't prepare this table 오류
OpenSearch Service 도메인 데이터를 Super-fast, Parallel, In-memory Calculation Engine(SPICE)으로 가져올 때 다음 오류 중 하나가 표시될 수 있습니다.
"Can't perform this Action. The domain X has not enabled cursor."
"Unable to prepare this table."
To activate the SQL cursor in your OpenSearch Service domain, run the following command:
PUT _opendistro/_sql/settings{
"transient": {
"opendistro.sql.cursor.enabled": "true"
},
"persistent": {
"opendistro.sql.cursor.enabled": "true"
}
}
Forbidden connection 오류
OpenSearch Service 도메인의 OpenSearch 대시보드에서 세분화된 액세스 제어를 활성화한 경우 다음 오류가 발생할 수 있습니다.
"GENERAL_SQL_EXCEPTION. Connection error forbidden."
이 오류는 Quick Sight 서비스 역할이 OpenSearch 서비스 역할에 매핑되지 않았기 때문에 발생합니다.
이 오류를 해결하려면 지침에 따라 도메인에 권한을 추가하여 Quick Sight에서 액세스할 수 있도록 허용하십시오.
관련 정보
Amazon Quick Sight와 함께 Amazon OpenSearch Service 사용
지원되는 데이터 소스
Amazon Quick Sight를 통해 VPC에 연결
Amazon OpenSearch Service의 운영 모범 사례