Athena: Delta Table DDL failed with an unexpected error.


I am trying to create the table using that following command that worked fine yesterday:

CREATE EXTERNAL TABLE IF NOT EXISTS `delta_gold`.`properties`
LOCATION 's3://org-delta/gold/properties/'
TBLPROPERTIES ('table_type' = 'DELTA');

, but today It creates the broken table without schema and important properties and error message as a result:

Delta Table DDL failed with an unexpected error.
This query ran against the ‘delta_gold’ database, unless qualified by the query. Please post the error message on our forum  or contact customer support  with Query ID: 47ea72b9-2b59-4ae0-8b82-dd0520715c1a
  • Facing exactly the same problem, starting today.

  • I also started suddenly having troubles with delta tables on Nov 3rd. I became unable to make new tables, but old ones stayed functional. If I drop the old tables and make a new one to the same table in S3, it will stop working despite the table not changing. Wondering if anyone has any updates on this? Working in us-east-1

  • I have the same problem on us-east-1. Changing to us-east-2 I had no problems creating new tables or performing a show create table

  • I am having the exact same issue. We can't create new delta tables or generate DDL on existing ones. Opened a support case and was told the Athena team is aware this is an issue.

질문됨 5달 전544회 조회
3개 답변

I'm experiencing exactly the same issue now.

답변함 3달 전

Me too -- trying to execute the query from a lambda fails with "unknown error". The athena, s3, and glue clients are all instantiated with an access token belonging to a root admin.

Retrying the query from AWS console simply works...

답변함 3달 전
수락된 답변

I haven't heard back yet, but this morning my team is not having this issue with Delta Tables on Athena anymore.

답변함 5달 전
  • You are right, worked on my side as well. Thanks.

로그인하지 않았습니다. 로그인해야 답변을 게시할 수 있습니다.

좋은 답변은 질문에 명확하게 답하고 건설적인 피드백을 제공하며 질문자의 전문적인 성장을 장려합니다.

질문 답변하기에 대한 가이드라인

관련 콘텐츠