내용으로 건너뛰기

Docker container fails to start

0

Someone can help me on this issue:

CannotStartContainerError: ResourceInitializationError: failed to create new container runtime task: failed to create shim task: failed to create init process I/O: 1 error occurred: * failed to start binary process: fork/exec /sbin/shim-logger-wrapper: argument list too long : unknown

the container is pulled from ECR. i'am trying to deploy a service on ECS.

질문됨 3년 전2.2천회 조회

1개 답변
0

This is related to a command in your Dockerfile or docker build file in your ECR that it is expanding as it's executing.

Try pulling image locally and debug it. Here's documentation about to pull image from ECR into Docker on your local machine: https://docs.aws.amazon.com/AmazonECR/latest/userguide/docker-pull-ecr-image.html

AWS

답변함 3년 전

로그인하지 않았습니다. 로그인해야 답변을 게시할 수 있습니다.

좋은 답변은 질문에 명확하게 답하고 건설적인 피드백을 제공하며 질문자의 전문적인 성장을 장려합니다.

관련 콘텐츠