"Something went wrong" Error when Attempting to Navigate to a DMS S3 Target Endpoint


During a recent release of DMS, Links to the details of Target Endpoints of Type S3 stopped working. The S3 buckets that are associated with the endpoints can be accessed via the S3 console and the Database migration tasks associated run without error. Also, all other endpoints work, even Source Endpoints of type S3. It is just the S3 Target endpoints that have this issue.

Here is the error message that is displayed when a link to the endpoint detail is clicked.

Enter image description here


Enter image description here

NOTE: After calling the cli command dms:describe-endpoints and comparing the output with the output from a test environment, there are no difference in the endpoint configurations.

However, the same error is now occurring in the test environment which has not been touched since January 26, at which point the error above was not present in both environments.

Below is the dsm:describe-endpoint output from a S3 Target Endpoint that is failing in the console.

	"EndpointIdentifier": "aaaa-bbbbbbbb-data-dev-blue-dms-target-endpoint-bronze-s3-cccccccccccccc",
	"EndpointType": "TARGET",
	"EngineName": "s3",
	"EngineDisplayName": "Amazon S3",
	"ExtraConnectionAttributes": "bucketFolder=CCCCCCCCCCCCCCC;bucketName=aaaa-us-east-1-bbbbbbbb-blue-data-bronze-dev;CdcPath=cdc-files;compressionType=NONE;csvDelimiter=,;csvRowDelimiter=\\n;datePartitionEnabled=false;",
	"Status": "active",
	"EndpointArn": "arn:aws:dms:us-east-1:111111111111:endpoint:VVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVVV",
	"SslMode": "none",
	"ServiceAccessRoleArn": "arn:aws:iam::111111111111:role/aaaa-bbbbbbbb-data-useast1-dev-blue-dms-s3-role",
	"S3Settings": {
		"ServiceAccessRoleArn": "arn:aws:iam::111111111111:role/aaaa-bbbbbbbb-data-useast1-dev-blue-dms-s3-role",
		"CsvRowDelimiter": "\\n",
		"CsvDelimiter": ",",
		"BucketFolder": "CCCCCCCCCCCCCCC",
		"BucketName": "aaaa-us-east-1-bbbbbbbb-blue-data-bronze-dev",
		"CompressionType": "NONE",
		"EnableStatistics": true,
		"IncludeOpForFullLoad": false,
		"CdcInsertsOnly": false,
		"ParquetTimestampInMillisecond": false,
		"CdcInsertsAndUpdates": false,
		"DatePartitionEnabled": false,
		"UseCsvNoSupValue": false,
		"PreserveTransactions": true,
		"CdcPath": "cdc-files",
		"UseTaskStartTimeForFullLoadTimestamp": false,
		"AddColumnName": true,
		"CsvNullValue": "''",
		"IgnoreHeaderRows": 1,
		"MaxFileSize": 50000,
		"Rfc4180": true,
		"AddTrailingPaddingCharacter": false
profile picture
질문됨 일 년 전322회 조회
2개 답변
수락된 답변


Sorry that you've been impacted by this. Our team has identified the issue while accessing DMS S3 target endpoint via AWS Console and a fix for the same is actively being worked on.

While this is being fixed, as a workaround, you can use the AWS CLI/API commands to describe the endpoint and get the details of the endpoints.

> aws dms describe-endpoints --filter="Name=endpoint-id,Values=s3endpointname"

[+] https://docs.aws.amazon.com/cli/latest/reference/dms/describe-endpoints.html

지원 엔지니어
답변함 일 년 전

Thanks for the quick reply.

profile picture
답변함 일 년 전
  • This issue has now been resolved.

로그인하지 않았습니다. 로그인해야 답변을 게시할 수 있습니다.

좋은 답변은 질문에 명확하게 답하고 건설적인 피드백을 제공하며 질문자의 전문적인 성장을 장려합니다.

질문 답변하기에 대한 가이드라인