RDS代理触发了InvalidParameterValue错误。

0

【以下的问题经过翻译处理】 你好,我很高兴RDS Proxy已经正式上线了。

我正在将RDS Proxy应用于我的Aurora MySQL 5.7.12集群,参考文档https://docs.aws.amazon.com/AmazonRDS/latest/UserGuide/rds-proxy.html

但我无法像下面这样注册DB Proxy Targets:

% aws rds register-db-proxy-targets --db-proxy-name my-rds-proxy --db-instance-identifier my-rds-cluster

An error occurred (InvalidParameterValue) when calling the RegisterDBProxyTargets operation: Database engine OSCAR 5.7.12 for DB Instance my-rds-cluster is not supported. Register the DB cluster instead of DB instance, or use another DB instance that is supported.

文档中说:“您可以使用RDS Proxy简化Amazon RDS DB实例和Amazon Aurora DB集群的连接管理。”但我的Aurora似乎无法做到。

有解决方案吗?

profile picture
전문가
질문됨 10달 전32회 조회
1개 답변
0

【以下的回答经过翻译处理】 你好,

根据您使用的命令,我发现注册RDS代理目标组的AWS CLI命令使用了 --db-instance-identifiers 选项,需要一个“实例标识符”,我怀疑提到了“集群标识符”。

对于集群,您可以使用选项“--db-cluster-identifiers”。上述信息在下面的文档中提到。

[+] https://docs.aws.amazon.com/cli/latest/reference/rds/register-db-proxy-targets.html

profile picture
전문가
답변함 10달 전

로그인하지 않았습니다. 로그인해야 답변을 게시할 수 있습니다.

좋은 답변은 질문에 명확하게 답하고 건설적인 피드백을 제공하며 질문자의 전문적인 성장을 장려합니다.

질문 답변하기에 대한 가이드라인