내용으로 건너뛰기

Using own domain for cognito. Rejected bc no A record. But I have one.

0

I've got a user pool and under app integration, domain name, I'm attempting to "use your own domain". When I put my www.mydomain.com into the field, it is rejected with

Custom domain is not a valid subdomain: Was not able to resolve the root domain, please ensure an A record exists for the root domain.

My domain _ cloudfront _ the origin S3 bucket all respond to both www and non-www requests in a browser and the route53 config has an alias A record pointing to the s3 bucket.

So I have an A record and it is valid. But still being rejected.

Could this be because my A record is an alias and not a pointer to a true IP address? If not, what's the issue?

질문됨 7년 전2.2천회 조회

1개 답변
0

I was trying to use "mydomain.com" in cognito which didn't work. And I couldn't immediately use "auth.mydomain.com" because my certificate didn't include that hostname.

I solved this by removing my cert from my cloudwatch distribution, deleting the cert and recreating it, this time with a new hostname "auth.mydomain.com" (in addition to the others). Once the subdomains were verified (in my case, through CNAMEs in Route53), I reattached the cert to my cloudwatch distro.

Then, in the cognito interface, I was able to use my own "auth.mydomain.com" domain. (The A record for "auth.mydomain.com" is an alias, so that wasn't the issue.)

답변함 7년 전

로그인하지 않았습니다. 로그인해야 답변을 게시할 수 있습니다.

좋은 답변은 질문에 명확하게 답하고 건설적인 피드백을 제공하며 질문자의 전문적인 성장을 장려합니다.

관련 콘텐츠