Appflow Snowflake Connectivity "Endpoint Request timed out"


Dear All ,

I am trying to connect my AWS Appflow to my Snowflake trial account. I have created the storage integration, and external stages in Snowflake and provided it the right role as well. I can see buckets in my S3 bucket while accessing it from Snowflake using the List <stage> command. When I try to fill in the connection details in Appflow and press connect, I am continuously getting the request timed out a message with event type "AWSAPI Call". I have created the S3 buckets in the same region as the Snowflake account and also increased the warehouse size to L but the issue still persists. Please help,

Thanks and kind regards, Vijay K Mohit

1개 답변

Hi Vijay,

I'm sorry to hear you're having trouble connecting AWS AppFlow to your Snowflake account. As someone on the AWS team, I'd like to offer some suggestions that could help troubleshoot this issue.

Credentials Check: It's always worth verifying the details first. Double-check the credentials you're using for Snowflake in AWS AppFlow. Make sure the username, password, account URL, warehouse, database, and schema are all correct.

Network Connection: Sometimes, the issue could be with the network. Ensure you're working with a stable internet connection and that no firewall rules or proxies are hindering the connection from AWS AppFlow to Snowflake.

Snowflake's Stage Settings: The stage setup in Snowflake can also be a culprit. Ensure that you have correctly set up the URL and credentials for your S3 bucket in the stage, and that the role in use has been granted the right privileges.

IAM Permissions: The IAM role used with AWS AppFlow should have the necessary permissions to access both your Snowflake account and the needed S3 resources. It's a good idea to revisit the permissions tied to that role.

Snowflake Network Policies: Snowflake's network policies might be preventing the connection. You might need to whitelist your network's IP or the IP range of AWS AppFlow.

Warehouse Size: While you've already tried increasing the warehouse size, it might be worth experimenting with different sizes or resetting it to the original setting. Resource contention or other issues could potentially be tied to this parameter.

AWS Service Status: Please do check the AWS Service Health Dashboard. On rare occasions, there might be a temporary issue on our side that could be causing this problem.

If none of the solutions work offer, please reach back out.

please find below some documentation to guide you further.

답변함 일 년 전
  • Dear VL ,

    Apologies I didn't get your full name from your profile. I have tried all the links and unfortunately this hasn't got resolved. After working with Snowflake teams it seems Appflow has an issue that it cannot parse Snowflake url if it has .aws in it. e.g. Some regions include UK region has .aws in their names and this is where Appflow fails to parse it and do not connect. I am really surprised that with the likes of AWS and Snowflake two biggest giants this issue hasn't been discovered in the testing or no-one else has raise it. I have recommended my client using AppFlow as this is the choice of tool to sync between AWS and Snowflake but because Appflow can't connect to Snowflake I have to find out an alternative solutions. Seems AWS needs to work internally with Appflow engineering team to get it sorted asap.

    Really appreciate all your support and sending me helpful links. Really appreciate it.

    Regards , Vijay

로그인하지 않았습니다. 로그인해야 답변을 게시할 수 있습니다.

좋은 답변은 질문에 명확하게 답하고 건설적인 피드백을 제공하며 질문자의 전문적인 성장을 장려합니다.

질문 답변하기에 대한 가이드라인

관련 콘텐츠