Minha instância do Amazon Elastic Compute Cloud (Amazon EC2) falhou em uma ou mais verificações de status.
Breve descrição
O Amazon EC2 usa três verificações de status para monitorar a integridade das instâncias do EC2:
Importante: algumas soluções de verificação de status exigem que você interrompa e execute sua instância. Uma reinicialização mantém a instância no mesmo host físico. Para migrar para um novo hardware, você deve interromper e iniciar a instância.
Resolução
Primeiro, veja as métricas de verificação de status da instância para identificar a verificação de status que falhou. Em seguida, realize as seguintes ações com base na verificação de status que falhou.
Configure sua instância para uma interrupção e execução
Observação: quando você interrompe e executa uma instância, o endereço IP público da instância muda. É uma prática recomendada usar um endereço IP elástico para rotear tráfego externo para a sua instância em vez de um endereço IP público. Se você usa o Amazon Route 53, talvez seja necessário atualizar os registros DNS do Route 53 quando o endereço IP público mudar. Uma interrupção e execução é diferente de uma reinicialização de instância. Para obter mais informações, consulte Como funciona a inicialização e a interrupção de uma instância do EC2.
Antes de interromper e iniciar sua instância, realize as seguintes ações:
Solucione falhas na verificação de status do sistema
As falhas na verificação do status do sistema ocorrem quando há problemas com a infraestrutura subjacente na qual sua instância é executada.
Para solucionar falhas na verificação de status do sistema, verifique o AWS Health Dashboard para ver se há interrupções de serviço na região da AWS onde sua instância está localizada.
Se não houver interrupções, então há um problema com o host subjacente da instância. Para solucionar esse problema, conclua as etapas a seguir para migrar a instância para um novo host subjacente:
- Interrompa a instância.
Observação: se a instância estiver presa no estado Stopping (Interrompendo), force a interrupção da instância. Essa ação pode levar até 10 minutos.
- Execute a instância.
Para recuperar automaticamente instâncias que falham nas verificações de status do sistema, configure a recuperação automática da instância.
Importante: uma interrupção forçada não libera os caches do sistema de arquivos e pode causar perda ou corrupção de dados. Depois de reiniciar, execute os seguintes comandos com base no seu sistema operacional (SO) para verificar se há erros de consistência no sistema de arquivos.
Linux:
fsck
Windows:
chkdsk
sfc /scannow
O comando chkdsk verifica o sistema de arquivos e os metadados do sistema de arquivos do volume para ver se há erros lógicos e físicos. O comando sfc /scannow verifica se os sistemas de arquivos estão corrompidos. Para obter mais informações, consulte chkdsk e Using System File Checker (Usando o System File Checker) no site da Microsoft.
Solucione falhas na verificação do status da instância
As verificações de status da instância identificam problemas com o sistema operacional, a configuração da rede e o uso de recursos. Para solucionar falhas na verificação de status da instância, use os seguintes recursos com base no sistema operacional da sua instância:
Solucione falhas de verificação de status do EBS anexadas
Se sua instância falhar na verificação de status do EBS anexada, verifique a métrica VolumeStalledIOCheck no Amazon CloudWatch para ver o volume afetado. Se o valor for 1, então o volume está com problemas. Normalmente, o Amazon EBS diagnostica e recupera automaticamente o volume em alguns minutos. Para obter mais informações, consulte I/O Características e monitoramento do Amazon EBS.
Para validar se o volume foi recuperado, verifique se VolumeStalledIOCheck muda para um valor de 0.
Se o problema persistir, interrompa e execute a instância para migrá-la para um novo host. Se um volume específico ainda apresentar problemas após a reinicialização, você deve substituí-lo. Crie um snapshot do volume e, em seguida, crie um novo volume a partir do snapshot. Use o novo volume para substituir o volume existente.
Informações relacionadas
Solucionar problemas de uma instância inacessível do Amazon EC2