AWS Builder Center: Learn, Build and Connect with builders in the AWS community
AWS Builder Center is the official home for builders on AWS. Share and read what others are working on, follow people who inspire you, explore training and workshops, and find tools to support what you're building.
Por que minha tarefa do Amazon ECS foi interrompida?
Quero solucionar minha tarefa do Amazon Elastic Container Service (Amazon ECS) que foi interrompida.
Resolução
Solucione problemas de tarefa interrompida
Use a chamada de API DescribeTasks para ver os detalhes de uma tarefa interrompida. Em seguida, solucione o problema da sua tarefa com base no motivo da interrupção e no código de saída nos detalhes da sua tarefa.
Os detalhes da tarefa interrompida aparecem somente por uma hora nos resultados da API. Para ter mais tempo para visualizar os detalhes da tarefa interrompida, use o modelo amazon-ecs-stopped-tasks-cwlogs no site do GitHub.
O contêiner essencial da tarefa foi encerrado
Se o contêiner essencial tiver sido encerrado, use um dos seguintes códigos de saída para solucionar o problema:
- O código de saída 0 ocorre quando o comando de ponto de entrada, sucesso ou CMD é concluído e o Amazon ECS interrompe o contêiner.
- O código de saída 1 ocorre quando há um erro na aplicação. Para solucionar esse código de saída, analise os logs da sua aplicação.
- O código de saída 137 ocorre quando você não responde a um SIGTERM dentro do período de 30 segundos e o Amazon ECS interrompe o contêiner com SIGKILL. Para alterar o período padrão de 30 segundos, atualize o agente de contêiner do Amazon ECS com o parâmetro ECS_CONTAINER_STOP_TIMEOUT.
Observação: esse código de saída também ocorre devido a erros de falta de memória. Para verificar seu uso de recursos, analise suas métricas do Amazon CloudWatch para o Amazon ECS. - O código de saída 139 ocorre quando a aplicação tenta acessar uma região de memória que não está disponível. Esse código de saída também ocorre quando um espaço reservado não definido ou de ambiente que não é válido causa uma falha de segmentação. Para solucionar esse problema, analise os logs do CloudWatch para suas tarefas do Amazon ECS.
- O código de saída 143 ocorre quando o contêiner recebe um aviso de desligamento ordenado e o Amazon ECS desliga o contêiner.
- O código de saída 255 ocorre quando o comando ENTRYPOINT CMD em seu contêiner falha devido a um erro. Para confirmar que seu contêiner falhou devido a um erro, analise seus logs do CloudWatch.
Para ver mais etapas de solução de problemas, consulte Como faço para solucionar problemas de tarefas do Amazon ECS que param ou não iniciam quando meu contêiner é encerrado?
CannotPullContainerError
Esse erro ocorre quando a tarefa falhou ao iniciar porque o Amazon ECS não consegue recuperar a imagem de contêiner especificada.
Para resolver esse problema em uma tarefa do tipo de execução do Amazon Elastic Compute Cloud (Amazon EC2), consulte Como resolvo erros "CannotPullContainerError" ao executar uma tarefa do EC2 no Amazon ECS?
Para resolver esse problema em uma tarefa do Amazon ECS que usa o tipo de execução do AWS Fargate, consulte Como resolvo o erro "cannotpullcontainererror" para minhas tarefas do Amazon ECS no Fargate?
A tarefa falhou nas verificações de integridade do Elastic Load Balancer
Para resolver esse problema em tarefas que usam o tipo de execução do EC2, consulte Como fazer com que minhas tarefas do Amazon ECS que usam o tipo de execução do Amazon EC2 passem na verificação de integridade do Application Load Balancer?
Para resolver esse problema em tarefas que usam o tipo de execução do Fargate, consulte Como solucionar falhas na verificação de integridade de tarefas do Amazon ECS no Fargate?
Verificações de integridade do contêiner que falharam
Você define verificações de integridade na API HealthCheck ou no Dockerfile. Para obter mais informações, consulte HEALTHCHECK no site do Docker.
Para solucionar erros de verificação de integridade de contêiner, consulte Como solucionar problemas na verificação de integridade de contêiner em tarefas do Amazon ECS?
A porta não está íntegra
Erros que contêm "Instance i-## port # is unhealthy" ocorrem quando uma instância não íntegra do Amazon EC2 não responde às verificações de integridade na porta especificada.
Para solucionar esse problema, realize as seguintes ações:
- Verifique se o grupo de segurança anexado à instância de contêiner permite o tráfego necessário.
- Execute o comando a seguir para confirmar se o backend responde sem atraso:
Observação: substitua container-port pela porta do seu contêiner e path pelo caminho da verificação de integridade.` curl -iv localhost:container-port/path` - Aumente o valor do tempo limite de resposta dos 30 segundos padrão. Atualize o agente de contêiner do Amazon ECS com o parâmetro ECS_CONTAINER_STOP_TIMEOUT.
Para obter mais informações sobre essa mensagem de erro, consulte Logs de acesso do Network Load Balancer.
O Amazon ECS está realizando a manutenção na infraestrutura subjacente que hospeda a tarefa
Esse erro ocorre quando o Amazon ECS executa a manutenção nos servidores do Fargate que executam os contêineres da sua aplicação. Como resultado, seu do serviço Amazon ECS fica temporariamente indisponível.
Para obter mais informações, consulte Retirada e manutenção de tarefas para o AWS Fargate no Amazon ECS.
Para tarefas autônomas, consulte Como faço para agir em relação a um aviso de retirada de tarefas do Amazon ECS para uma tarefa executada no Fargate?
Evento de escalabilidade de serviço do Amazon ECS ativado
Durante um evento de escalabilidade de serviço do Amazon ECS, as tarefas são interrompidas porque a política de escalabilidade reduz o número de tarefas executadas no serviço. Em seguida, o Amazon ECS interrompe as tarefas para alcançar o novo número especificado. Essa ação normalmente ocorre quando a demanda diminui e o Amazon ECS exige menos tarefas para lidar com o workload.
Para solucionar esse problema, realize as seguintes ações:
- Crie alarmes do CloudWatch para mudanças em seu serviço ou tarefas.
- Analise as implantações programadas que podem afetar suas tarefas.
Para proteger suas tarefas do encerramento de eventos de redução de escala horizontalmente devido ao ajuste de escala automático ou às implantações de serviços, use a Proteção de tarefa na redução de escala do Amazon ECS.
Para obter mais informações, consulte Como faço para visualizar e gerenciar ações de scaling programadas para os serviços do Amazon ECS?
Tarefa que um usuário interrompeu
Para identificar quem iniciou uma chamada de API StopTask, consulte StopTask no AWS CloudTrail para obter informações de userIdentity.
ResourceInitializationError
Para diferentes mensagens de erro ResourceInitialization e etapas de resolução, consulte Solução de problemas causados por erros ResourceInitializationError do Amazon ECS.
Para solucionar o erro "ResourceInitializationError: unable to pull secrets or registry auth", consulte Como resolvo um "ResourceInitializationError" quando tento extrair segredos ou recuperar a autenticação do Amazon ECR para tarefas do ECS?
Para solucionar o erro "ResourceInitializationError: failed to validate logger args", consulte Como resolvo o erro "ResourceInitializationError: failed to validate logger args" no Amazon ECS?
SpotInterruptionError
Para obter mais informações sobre o erro SpotInterruptionError, consulte Solução de problemas causados por erros SpotInterruption do Amazon ECS.
Para solucionar esse erro, consulte Como faço para gerenciar os avisos de encerramento do Spot nas tarefas do Fargate Spot?
OutOfMemoryError
Esse erro ocorre quando um contêiner é encerrado porque os processos no contêiner usam mais memória do que você alocou na definição da tarefa.
Para solucionar esse erro, consulte Como soluciono erros de OutOfMemory no Amazon ECS?
Solucione as mensagens de erro que você recebe quando sua tarefa é interrompida
Se você receber uma mensagem de erro quando sua tarefa for interrompida, realize as seguintes ações de solução de problemas com base no erro.
No Container Instances were found in your cluster
Para resolver esse problema, execute uma instância de contêiner.
Para analisar as instâncias do seu cluster, conclua as etapas a seguir:
- Abra o console do Amazon ECS.
- No painel de navegação, clique em Clusters.
- Selecione seu cluster.
- Clique na guia Infrastructure (Infraestrutura).
- Analise a seção Container instances (Instâncias de contêiner).
Se não houver instâncias de contêiner, consulte Por que minha instância do Amazon EC2 não pode se juntar ao cluster do Amazon ECS?
InvalidParameterException
Para resolver essa mensagem de erro, verifique se os parâmetros em sua TaskDefinition existem e se têm os nomes de recurso da Amazon corretos. Verifique se o perfil da tarefa e o perfil de execução da tarefa têm as permissões necessárias.
You've reached the limit of the number of tasks that you can run concurrently
Esse erro ocorre quando você excede uma cota de serviço do Amazon ECS. Para solucionar esse problema, consulte Como resolvo problemas de cota de serviço do Amazon ECS?
Informações relacionadas
- Tópicos
- Containers
- Idioma
- Português
Vídeos relacionados


Conteúdo relevante
feita há um ano
feita há um ano
AWS OFICIALAtualizada há 2 anos