Amazon SSM agent service not starting

1

Hi, I have a few Windows instances that are having issues with te Amazon SSM Agent service.
The event log is showing the following:
The Amazon SSM Agent service terminated with service-specific error Incorrect function

error log is also showing:
ERROR [HandleAwsError @ awserr.go.48] [instanceID=my_instance_id] [MessageProcessor] error when calling AWS APIs. error details - GetMessages Error: NoCredentialProviders: no valid providers in chain. Deprecated.
For verbose messaging see aws.Config.CredentialsChainVerboseErrors
2017-08-12 22:50:05 ERROR [HandleAwsError @ awserr.go.48] [instanceID=my_instance_id] [HealthCheck] error when calling AWS APIs. error details - NoCredentialProviders: no valid providers in chain. Deprecated.

Please help, thanks!

auxjimk
feita há 7 anos7527 visualizações
6 Respostas
0

Hello,

The SSM agent error indicates that it is not able to find the credential to connect and authenticate with SSM APIs endpoints.

On your instance make sure that you have an IAM Role attached or the Credential file (for AWS CLI) configured properly with necessary IAM policy. You may take a look at our below public document about configuring SSM agent:
http://docs.aws.amazon.com/systems-manager/latest/userguide/ssm-agent.html

Regards,
Santosh K

respondido há 7 anos
0

Hi.

I have the same issue but the event viewer show " incorrect Function" thats the only log i have.

regards!

respondido há 7 anos
0

also the error log shows...

ERROR error occurred when starting core manager: Failed to fetch region. Data from vault is empty. Get http://169.254.169.254/latest/dynamic/instance-identity/document: net/http: request canceled while waiting for connection (Client.Timeout exceeded while awaiting headers)

Please any suggestion?

respondido há 6 anos
0

Hi everyone,

My problemm was that i can not fetch metadata.
and the solution was EC2 Launch.

Here the solution:
http://docs.aws.amazon.com/es_es/AWSEC2/latest/WindowsGuide/ec2launch.html

regards!

respondido há 6 anos
0

This forum is old, but I wanted to provide the reason for my failure in case anyone stumbles on this problem. I was also getting the metadata failure. I noticed I couldn't get to http://169.254.169.254/latest/meta-data/instance-id in a browser either. I had NMAP installed which installs a loopback network device. This network device was set with IP 169.254.x.x with a subnet of 255.255.0.0. So, all requests to 169.254.169.254 were being sent to that loopback device and not to AWS. Disabling the loopback adapter fixed it.

kg4ysy
respondido há 5 anos
0

I had the same issue on my hyper-v instance. To get the amazon ssm agent working again I first disabled my hyper-v switch for testing. The SSM agent started right away. Next I enabled my hyper-v switch and ran the commands here for adding the metadata routes - https://repost.aws/knowledge-center/waiting-for-metadata

Prior to doing anything I ran "Route print" from a command prompt. The metadata routes were there under persistent routes, but they were not in the "active routes" table. After adding the routes via the above commands my ssm agent service was able to start successfully

AWS
respondido há um ano

Você não está conectado. Fazer login para postar uma resposta.

Uma boa resposta responde claramente à pergunta, dá feedback construtivo e incentiva o crescimento profissional de quem perguntou.

Diretrizes para responder a perguntas