Ir para o conteúdo

postgreSQL aurora serverless v1 upgrade from 11.21 to 13.12

0

Since postgreSQL 11.21 has reached EOL, we are trying to upgrade it to 13.12. Initially the upgrade was failing at the precheck stage due to postgis. Resolved that, the upgrade is proceeding past the precheck, but it's still failing. From the CloudWatch logs:

*failure*
There were problems executing ""/rdsdbbin/aurora-13.12.13.12.7.14976.0/bin/pg_restore" --host /rdsdbdata/log/upgrade --port 5433 --username **myuser** --create --exit-on-error --verbose --jobs 1 --dbname template1 "pg_upgrade_dump_16408.custom" >> "pg_upgrade_dump_16408.log" 2>&1"
Consult the last few lines of "pg_upgrade_dump_16408.log" for
the probable cause of the failure.
"/rdsdbbin/aurora-13.12.13.12.7.14976.0/bin/pg_ctl" -w -D "/rdsdbdata/db" -o "--config_file=/rdsdbdata/config_new/postgresql.conf --survivable_cache_mode=off" -m fast stop >> "pg_upgrade_server.log" 2>&1

Is there any way to Consult the last few lines of "pg_upgrade_dump_16408.log" for the probable cause of the failure.? Or any idea on how to solve the issue?

Also, I masked the --username **myuser** bit from the log, but not the --host /rdsdbdata/log/upgrade, that looks strange/wrong (or is it some automatic masking?)

feita há 2 anos352 visualizações

1 Resposta
0
Resposta aceita

This seems resolved now,

not sure if ti was just a temporary issue that got resolved after a new attempt, like in https://repost.aws/questions/QUdN7XUmg8R9u-qtZNy_T-_w/access-log-file-from-failed-upgrade-from-postgresql-10-7-to-11-2#ANjDKCqn5qRqCssfxMEqzJaQ

or if it was still an issue related to postgis_raster extension. In fact after updating the postgis extension, the postgis_raster was still trying to use some old 2.* system libraries, and I followed steps reported in https://repost.aws/questions/QUP1Suk7DnSMqEZMCBkOGoBQ/rds-postgresql-engine-upgrade-from-10-21-to-14-4-version#ANpno0pqFPQXO9HtAgs4Tmqw

but maybe that was not enough, so I also tried https://postgis.net/stuff/uninstall_rtpostgis.sql before triggering again the cluster upgrade, that this time worked without errors.

We'll check how it goes, doing the same process in the other environments.

respondido há 2 anos

ESPECIALISTA

avaliado há 2 anos

  • This worked also with another cluster in another environment/account

Você não está conectado. Fazer login para postar uma resposta.

Uma boa resposta responde claramente à pergunta, dá feedback construtivo e incentiva o crescimento profissional de quem perguntou.