pending "create-fpga-images" using aws ec2

0

Hi all.. I've tried to create aws-fpga-images with xclbin files generated by v++. the detailed situation I've met now is below,

  1. created "awsxclbin files" using command "aws ec2 create-fpga-images -xclbin={my_xclbin} -o={my_awsxclbin_name} -s3_bucket={my_bucket} -s3_dcp_key={my_dcp_repo} -s3_logs_key={my_log_repo}"
  2. all txt, json, and awsxclbin files were successfully generated in my local linux machine.
  3. "aws ec2 describe-fpga-images --fpga-image-ids {generated_afi_ids}" showed the bitstream is pending (still pending)
  4. opened aws ec2 website
  5. I found that the .tar file generated by aws ec2 command exists in {my_dcp_repo}
  6. I couldn't find the vivado log files in {my_log_repo}

However, my request status for create-fpga-images is now still pending. (the request was created on Aug 25 2022). Can I find the detailed status of the ongoing request on aws websites?

asked 3 months ago60 views
2 Answers
1

Dear customer,

Thank you so much for your interest in AWS. Thanks for providing the detailed commands you used to create the AFI. AWS requires that you use create_vitis_afi.sh script to generate AFI when using Vitis as documented in https://github.com/aws/aws-fpga-staging/tree/develop/Vitis. However, I see that you used create-fpga-images to create AFI with vitis flow. The create-fpga-images tool is used for HDK flow. Can you please try using create_vitis_afi instead. reference: https://github.com/aws/aws-fpga-staging/tree/develop/Vitis

In addition, can you also provide details on any reference you possibly encountered where if create-fpga-images was recommended/used in the documentation to create AFI with vitis flow.

Thanks

answered 3 months ago
  • Thank you for your reply on my question. I've tried to use create_vitis_afi.sh when I created awsxclbin, and this was not a workaround for this issue. afi and agfi were successfully generated, but 'pending' was not turned to 'fail' or 'available'. the file size of the xclbin is 1.1GB, generated by 2021.2 vitis.

    My last 'available' awsxclbin was created with xclbin generated by the same version of vitis. and its file size was 850MB. is there the way to check whether the 'pending' is being proceeded?

    Special Thank you.

    ps. my design is fully fit in 2021.2 and I cannot modify the design to fit in 2022.1

    ++added at 8:28 am (south korea)++

    Now current afi status is not being updated "State": { "Code": "pending" }, "CreateTime": "2022-08-28T04:00:02+00:00", "UpdateTime": "2022-08-28T04:00:02+00:00",

0

Dear customer, can you please provide the following details 1.) which version of the developer AMI are using while trying this run. 2.) Which version of the developer kit are you using 3.) Are you able to run this flow with one of the examples provided in the developer kit for Vitis? i.e, are you seeing this issue only with your design or are you seeing this with examples provided in developer kit as well?

Thanks

answered 3 months ago
    1. I used ./create_vitis_afi.sh not in AMI, but in my local linux machine.
    2. if the verison of the dev. kit means the tag of the "aws-fpga" github, I've checked out the github tag as v1.4.23.
    3. Yesterday, I've implemented fpga dcp from the RTL-level synthesis of my ANOTHER design and i created the awsxclbin, which was generated and turned to 'available' in s3 bucket successfully.

    Thank you.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions