Error when deleting Inference Endpoint in Sagemaker using CLI


I am trying to delete my inference endpoint using the AWS CLI because I can't do so via the Studio. However, when I try to list the inference components using

aws sagemaker list-inference-components

command, I am getting an error of 'aws: error: argument operation: Invalid choice'. There does not seem to be a list-inference-components command in the AWS CLI . I tried using boto3 and got into the same error. Can someone please help?

2 Answers
Accepted Answer


The command exists.
Also, if you are running the command with options, check that the options are set correctly.

Please upgrade the AWS CLI version to the latest version and try again.

Or try setting the AWS CLI execution environment to CloudShell.

profile picture
answered 4 months ago
profile pictureAWS
reviewed 4 months ago

It works after upgrading the AWS CLI - thanks!

answered 4 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions