How to change back throttling to "not configured" on HTTP API Gateway after configuring values on it.


Hello community. IHAC that did a change on HTTP API Gateway and and configured throttling. After some testing they wanted to configure it back to "not configured" or change it back to default, but it is not possible

It seems it only accepts either integer values from 0-10000 and we cannot change it back to Null or Unconfigured. Is there any way to change it back to "not configured" status?

Best regards


asked 2 months ago29 views
2 Answers
Accepted Answer


"Not Configured" would not mean that rate limiting was not applicable for the API gateway. In the absence on any configuration the account level settings would take effect and that is the 10000 you see as the max value . Though it's kind of weird that you cannot set the value back to Not configured or null, I would assume setting it to the max permissible for the account would essentially (logically) mean the same as not have configured the value specifically and hence be bound by the account upper limits per region


profile picture
answered 2 months ago
  • Thanks for your help in that. Yes it seems it is the only way to make it happen but I wanted to see if we get a different approach to this question. Thank you!!


Hello Carlos, thanks for the clear description. Currently, it's not possible to revert the change back to "not configured."

While you cannot "disable" the default route throttling, the workaround is to set it to account-level throttling rates, namely 5000/10000 respectively for burst/rate limit [1]. This is identical to the "not configured" setting as this account-level throttling is implicitly enforced all the time.


answered 2 months ago
  • Thanks so much! Seems it is the only workaround possible. Maybe in the future.

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions