INVALID_PAYMENT_INSTRUMENT after requesting model access in Amazon Bedrock

1

Hi,

I was trying to use the GA Amazon Bedrock, but I received the following error when I tried to request models access:

Amazon Bedrock errors

This account has been active a few years and we're currently using many other services without any troubles. They payment methods are properly set in our organization and, again, there have been no issues so far on other services.

Did I miss any configuration somewhere?

Thanks in advance!

frand
asked 9 months ago2601 views
3 Answers
4
Accepted Answer

I resolved this issue by changing our default payment method from a SEPA type to a CREDIT CARD type. I was able to complete the purchase through Bedrock, and change our defaults back afterwards.

daveok
answered 8 months ago
profile picture
EXPERT
reviewed a month ago
profile picture
EXPERT
reviewed 3 months ago
  • Yes! Definitely that was it and that's how we solved it on our side. I forgot to post the answer here. It took a while before we understood the issue.

    Thanks!

0

I have additional info. I cannot subscribe to Foundation Models in Amazon SageMaker either. Inspecting the Network tab in the developer tools of my browser, the requests return the same error for the model subscription no matter which region I'm in.

There's definitely something wrong with my account.

frand
answered 9 months ago
0

Please note, SEPA is not the only type of payment type not supported for Marketplace. Per this blog post, some India based customers will also be affected. As others have already called out, you can update your payment preference in the console.

AWS
Petz
answered 3 months ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.

Guidelines for Answering Questions