Skip to content

BUG | Elasticache | Changing Cluster Mode from "disabled" to "compatible" Error | Must specify a parameter group for cluster mode update.

0

I am attempting to update a Redis OSS Cache to use cluster mode compatible (and eventually enabled). It is currently disabled.

I've tried to do this both through terraform and through the AWS Console. I get the same error in either case: Must specify a parameter group for cluster mode update.

The problem is that my Redis OSS Cache already has a parameter group assigned? So seems like a bug.

I am using Redis Engine 7.1.0

asked 2 years ago696 views

1 Answer
2

Hello.

To enable cluster mode from ElastiCache Redis with cluster mode disabled, you need to set it to "cluster-enabled" in the parameter group.
Therefore, to enable it from a disabled state, you need to create a custom parameter group with "cluster-enabled" enabled in advance, and then change the parameter group at the same time when changing the cluster mode.
https://docs.aws.amazon.com/AmazonElastiCache/latest/red-ug/modify-cluster-mode.html

EXPERT

answered 2 years ago

EXPERT

reviewed 2 years ago

EXPERT

reviewed 2 years ago

You are not logged in. Log in to post an answer.

A good answer clearly answers the question and provides constructive feedback and encourages professional growth in the question asker.